2

I noticed that when I migrated from backing up over USB to SMB that Time Machine started using sparse bundles for backup. I was unsuccessful in using this bundle as a backup drive when connecting to the hard drive directly via USB.

I tried mounting the bundle, but macOS complained about insufficient permissions. I then took ownership of the bundle and successfully mounted it manually — still not listed in the Time Machine settings.

Is it possible to back up to a local sparsebundle? I would like to default to SMB backups, but have the choice to use USB3 for speed.

2

Time Machine should automatically mount the .sparsebundle if you set the drive that contains it as the backup location.

Failing that, you can double click the .sparsebundle to mount it, then tell Time Machine to backup to the mounted volume (something like /Volumes/Time Machine Backup). This might be an acceptable workaround if you only infrequently use it over USB3.

If you don't see the mounted .sparsebundle as an option in time machine you can set it manually via the terminal like so:

sudo tmutil setdestination /Volumes/Time\ Machine\ Backup

Just change the Time\ Machine\ Backup part to whatever your drive is called.

  • Could you elaborate on how I would tell it to backup to the mounted volume when the volume doesn't show up in Time Machine settings? – Andreas Mar 6 at 13:53
  • You can use sudo tmutil setdestination /Volumes/foo. That should be the location that the .sparsebundle is mounted at. – chmac Mar 6 at 21:04
  • I tried part of it now just to try and restore from the bundle, but I had no success. The sparsebundle is on an NTFS volume and could not be mounted apparently. Perhaps now that APFS has proved to be very unreliable and forcing me to reinstall macOS I will have to reevaluate the benefit of having the backup on HFS instead of NTFS, if that was the reason it couldn't be mounted. – Andreas Apr 10 at 12:23
  • I've had the opportunity to try this out. After creating a sparsebundle with disk utility and mounting it it doesn't show up in Time Machine settings, but your solution works. The only thing that didn't seem to work for me was having it automatically mount the sparsebundle when setting the containing volume as the backup location. – Andreas May 3 at 10:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .