7

I require Polish diacritics, such as ą, ć, ę, etc.

Of course, I can always pre-process the file to replace UTF-8 characters with escaped characters but that's not elegant.

2
  • you mean like this (press and hold) then pick one ç ,ć, č, ß, ś, š
    – Ruskes
    Commented Nov 5, 2018 at 19:44
  • Sorry for the confusion. The problem is not to enter the characters into the .ms file but to have groff render then properly in PS output. Commented Nov 5, 2018 at 20:02

2 Answers 2

4

As of today, macOS Mojave ships with a quite outdated version of groff (1.19 or something...) which apparently cannot handle the -K option. Thus it fails to recognise any fancy diacritics (german umlauts in my case), if you run groff -Kutf8 ....

You can get a newer version of groff on macOS by installing it via Homebrew, as per this post

brew install groff gs

(not sure if gs for ghostscript is actually required; I installed it anyway)

2
  • The -k alone option ("Process with preconv") seems to do the right thing without having to specify the encoding, at least for my very simple use case of Unicode ellipses. However, -Tutf8 is still required to display the actual UTF-8 characters properly in the terminal.
    – Kevin E
    Commented May 19, 2022 at 6:33
  • Apple was using old versions because of GPL 3. Ventura removes groff completely.
    – Polluks
    Commented Jul 19, 2022 at 8:42
1

The following convoluted way works:

groff -Kutf8 -Tdvi -mec -ms test.ms > test.dvi
dvipdfm -cz 9 test.dvi
open test.pdf

Via the [Groff] latin2 polish special characters thread on lists.gnu.org.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .