1

I've updated to macOS Mojave weeks ago, and everything was working very well. However, yesterday my iMac (2014, I think?) didn't even boot, nor does it today.

The verbose mode shows this (I know I should post text, but I can't, for obvious reasons):

enter image description here

I found only one question about the same error message on Apple forums, but it doesn't have any answers...

The boot drive check (from recovery mode and via fsck from Single user mode) didn't find any errors.

How can this be solved?

  • try running the fsck multiple times – Ruskes Nov 5 '18 at 16:34
  • you do have a disk error...disk1s1: device is not readable – Ruskes Nov 5 '18 at 16:37
  • it would be helpful if you wait till the Safe boot stops and show us the last lines. – Ruskes Nov 5 '18 at 16:53
  • @Buscar웃, just ran fsck -fy 2 times, and it shows "The volume /dev/rdisk1s1 appears to be OK". Furthermore, I'm writing this from Windows that's installed on the same HDD, so the drive should be OK. – ForceBru Nov 5 '18 at 17:27
  • please report the last lines when the Verbose mode stops .... – Ruskes Nov 5 '18 at 17:31
1

I run fsck -fy three or four times, as suggested in the comments, but it didn't reveal any issues and kept telling me "The volume /dev/rdisk1s1 appears to be OK".

I was lucky to have Windows installed alongside macOS with Bootcamp, so I booted into Windows to see whether the data on the macOS partition were fine. It turned out that one can't just view APFS drives in Windows, so I had to install a trial version of APFS by Paragon, which allows you to mount such drives from Windows.

The partition mounted successfully, and I was able to see all my data, so, apparently, nothing was lost or corrupted. I was even luckier to have a spare hard drive lying around and a device to connect it to a computer through USB, so I did that and copied the vast majority of my files from the (faulty?) macOS partition to this drive.

After the data were safe, I rebooted into Recovery mode, checked the partition from Disk Utility once again, which showed "...appears to be OK" again, and tried to reinstall the OS.

I know the installation process is supposed to be kinda long, but this one was insanely long. Everything seemed to have installed (no errors whatsoever), and it attempted to boot itself. It was doing that and showing me the usual apple logo on the white background and a full progress bar for literally fifteen hours because I was told to "let it work" and that it might repair the drive in the comments, and was hoping not to lose any data. Well, that went nowhere, so finally I just shut the Mac down. (BTW, after booting from Windows again I found out that all the data on the macOS partition were still intact)

I ended up wiping the macOS partition from the Disk Utility in the Recovery mode and installing macOS once again. This worked fine, and I got a fresh macOS Mojave installation, from which I'm writing this (semi-)answer. I can access all the data I copied to the external drive, nothing is corrupted.


TL;DR - did a backup (the partition was not corrupted), nuked the partition from orbit and did a clean installation; still no idea why this happened.

0

If it helps, i have 4 macs that all do this randomly. black screen or just the logo on boot. the only boot option that works is recovery (and that is on another partiation). On my iMac i can do an install (last time tried a complete new with migration) and first reboot after running a few hours back to the Apple. I did try booting from a USB drive when it would not boot from the Apple internal SSD (imac) and that worked. I cam cloning the boot disk over to an external usb SSD drive to see how long that works. I don't know if this is an hardware thing (odd that 4 different macs have the issue) or a Mojave thing. I have sent in several feedbacks with no luck. if I can prove it works using USB reliably I guess I will drive the 40 mils to an apple store.

  • Four macs?! That has to be to do with Mojave, dude! Personally, I’ve never ever run into anything like that for years, with the same iMac. Now that you have four acting up, Apple must’ve messed something up in macOS. The data seems to be fine, though, so it’s not that bad. – ForceBru Dec 4 '18 at 19:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .