2

I hate the transparent menubar in modern macOS versions. I used to avoid this by enabling the "Reduce Transparency" option in System Preferences > Accessibility > Display.

In Mojave (on non-Retina systems) this has nasty side effects and generally makes everything look like garbage.

I found a hidden setting that apparently used to work, but has no effect in Mojave:

defaults write NSGlobalDomain AppleEnableMenuBarTransparency -bool false

My current poor-man's workaround was to create a 1920x1080 PNG with my preferred background picture, and add a 22px high 100% white bar at the top. This simulates the effect of having an opaque menu bar.

Does anyone know of a better way?

edit: to help illustrate the difference, check out the side-by-side comparison below. The image on the left is with my "hack" of placing a 22px high 100% white strip across the top of an otherwise solid gray background. On the right is the same transparent menu drawn on top of Apple's "stock" solid background. Note the reduction in readability/contrast: comparison

  • does it gives you any errors with the defaults write NSGlobalDomain AppleEnableMenuBarTransparency ? is that maybe under the SIP protection ? – Ruskes Nov 5 '18 at 2:21
  • @Buscar웃 - No errors, but changing the setting simply has no effect. – luckman212 Nov 5 '18 at 23:48
  • Your using a patched OS correct? dosdude1 mojave patch has graphics problems in the light mode for metal graphics card transition... – anais Jan 22 at 1:27
  • Thank you for the poor-man's workaround idea. This was driving me crazy. Unfortunately, I can't offer any sane solutions. Apple just keeps screwing with us. – RSummers Feb 6 at 22:59
0

On my MacBook Air (Early 2014) checking the box "Reduce Transparency" does the trick:

System Preferences > Accessibility > Display

It being an older Mac (non-retina) I'm wondering if it works the same on newer Macs with/without retina display.

  • In my OP I mentioned that this was the method I've always used in the past. Sadly, on Mojave, along with the font rendering changes & removal of subpixel antialiasing, UI elements with transparency are not rendered properly in "Reduce Transparency" mode. They often show up as dark grey with black text, and are at times completely unreadable. – luckman212 Nov 5 '18 at 23:47
  • I mention it because I have a non-retina display with that OS. There may be something wrong with your install as it makes no sense that Apple would mess up that badly wit a feature like that. – Steve Chambers Nov 6 '18 at 14:45
  • I agree with you that "it makes no sense" but I'm not the only one who noticed the negative changes with Reduce Transparency mode + Mojave. Here is one example, and another. There are plenty more if you search for them. – luckman212 Nov 7 '18 at 17:38

You must log in to answer this question.

protected by Mark Feb 7 at 13:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .