I'm trying to restart my MBP (now running Mojave) in safe mode, and for whatever reason holding down shift isn't doing the trick (this complaint is scattered across the internet). Apple offers this alternative for cases in which you don't have a keyboard:

Access the command line by opening Terminal remotely, or logging into the computer using SSH.
Use the following Terminal command:
sudo nvram boot-args="-x"

Unfortunately, when I run this command I get nvram: Error setting variable - 'boot-args': (iokit/common) not permitted. Googling this error gets me a pointer to this bit of info:

...you must use the nvram command to properly set boot-args NVRAM variable. Starting with macOS Sierra, you must be booted to the recovery partition to run this command.

Booting from the recovery partition sounds even harder than getting into safe mode, so it appears I am back to square one. Are there any other ways to get to safe mode?

  • What happens when you attempt to boot into recovery by restarting, and holding command-R at the chime? Nov 4, 2018 at 19:07
  • @David the OP already answered that
    – Ruskes
    Nov 4, 2018 at 19:14
  • @Buscar웃 The OP said "Booting from the recovery partition sound even harder than getting into safe mode, so it appears I am back to square one." While this suggests the OP may have tried booting into recovery, it doesn't actually say that. Did s/he? We don't know. Nov 4, 2018 at 19:26
  • @David so do you have the process for booting in to safe mode from recovery mode, so to explain to the OP what to do.
    – Ruskes
    Nov 4, 2018 at 19:29
  • 1
    Using a different external keyboard as suggested by @Buscar웃 works!
    – kuzzooroo
    Nov 5, 2018 at 13:25

1 Answer 1


Problems with MBP's internal keyboard and Mojave not Restarting in Safe mode using Shift key, can sometimes be resolved using External keyboard instead.

Not the answer you're looking for? Browse other questions tagged .