I no longer get any autocompletion results when I begin to type a standard header file name in the include statements:

#include <>

Normally, typing in a name such as vector or string would cause the autocompletion list to open and display results for these library names, but it is not happening in Xcode 10. I'm getting some autocompletion results for other headers, but nothing related to the standard C++ libraries. Does anyone know any workarounds or solutions to this? I asked in the Apple developer forums, but I've received no help after a week now.

I know that directory for standard C++ library files is:


But I'm unaware where this would be placed in Xcode to hopefully get it to allow for autocompletion of headers for all projects in Xcode (and not just whatever specific project is loaded.

Any help is greatly appreciated.

If there isn't a workaround, can anyone else with Xcode 10 verify this issue on their end?

  • Did you try deleting the Derived Data folder and restarting Xcode? That's usually the first troubleshooting step I do.
    – fsb
    Nov 4, 2018 at 14:05

1 Answer 1


I can confirm same behaviour on my machine. But you can have the autocompletion for C++ back if you add the include path specified in Build Settings -> Search Path -> Header Search Path. See the picture below.

enter image description here

For all/many C++ projects you may add/modify the Custom Paths in Xcode Preferences-> Locations -> Custom Paths.

  • Did it work for you before Xcode 10? Secondly, I believe I tried to add the path to the custom path section and I don’t think it was working for me. I didn’t try to add it to the build section as I wanted it for all projects.
    – joe_04_04
    Nov 4, 2018 at 19:49
  • Just to follow up, including the path in the per project header section works, but not in the global Xcode path section, unfortunately.
    – joe_04_04
    Nov 5, 2018 at 3:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .