1

At our home, we pay for 20 Mbps Internet connection to operator. On computers and tablets we get full speed via Wi-Fi, while on iPhone 7 and iPhone XR we gat max 2.7 Mbps. We live in apartment with maybe 20 different wireless networks.

  1. We tried different channels - no change in behaviour on our iPhones.

  2. We tried phones at our company Wi-Fi networks - we got around 17 Mbps there, so phone hardware is capable of receiving more data.

  3. We bought new modem/router Asus DSL-AC55U which can stream also on 5 Ghz - still same behaviour.

  4. We called with provider on the phone trying to change settings - no effect, still same behaviour.

  5. we have tried on phones change DNS server to manual, we tried googles and others - still same behaviour.

I believe that there is problem with Wi-Fi settings. Anyone has idea how to resolve this issue?

migrated from superuser.com Nov 3 '18 at 17:55

This question came from our site for computer enthusiasts and power users.

  • Make sure WMM is enabled on your Wi-Fi AP: It is required for 802.11n and 802.11ac. Also make sure you're using WPA2 security; WEP and original WPA are not allowed for 802.11n and 802.11ac. Give your router a separate SSID for 5GHz and have your phones join that, and make them forget the 2.4GHz SSID. Make sure your AP's 5GHz radio is set for 80MHz-wide channels. – Spiff Nov 3 '18 at 22:15
1

The following observation indicates to a problem specifically for iPhones in contrast to e.g. iPad and maybe related to your problem.

I had problems to convince my iPhone 6s to use the 5GHz band. iPad and iMac did it at once after I switched off the 2.4 GHz in the router. The iPhone would not connect, even after resetting the network settings. The trick I used (not my own idea) was to use two different SSIDs for 5GHz and 2.4Ghz. Even then it took two or three attempts, but now the iPhone connects to the 5GHz.

0

The problem looks so strange as you say that phone got around 17Mbps at company. The best way I think would be to contact wifi provider. Also make sure that the wifi you are using is not set as something like metered connection in win 10.

  • Thanks, but in point 4 i mention, that we called with them 3 times, no success. but thanks. – Brano Nov 3 '18 at 12:45
  • Did you try checking if you have marked the wifi as mobile network or metered network? – m__ Nov 3 '18 at 12:50
  • Kind of, we dont have windows computer so I googled and i understood it simply if there is a bandwidth limit for mobile devices. I did not find any similar settings in router so I assume no, we dont have limit there. – Brano Nov 3 '18 at 12:54
  • Setting in phone. – m__ Nov 3 '18 at 13:14
0

Most likely, your Internet connection is not related to any of this. Try doing a local speed test (between wifi device and, if possible wired device). A classical way to do that is to use iPerf (seems there's a $1 app for iOS), but you could try FTP, HTTP or any other, and see if you get more that 2.7 MBps. My bet: you won't. If you do, then try sharing wired connection from a wired computer over wifi, just to see if you have an issue with your router.

Oh, and just make sure you're connected on the 5 Ghz network.

You must log in to answer this question.