I’ve been having trouble fixing the “macOS needs to repair your library” loop for the past couple of days and I’m running out of options. The message pops up over and over again, no matter what I do.

enter image description here

I’ve gone as far as typing a command in Terminal (recovery mode) which Apple support sent me (the diskutil resetuserpermissions, except longer).

I found some other commands online but I’m not sure what they do and that’s why I haven’t tried them, can anybody help me?

Other commands I’ve found: resetpassword (confused as to WHICH password it’ll reset) and

sudo chown -R <user> ~/Library

sudo chgrp -R <groupname> ~/Library (found on this website)

This last one the user said I should get it by running id -u for user and id -g for groups, but as I am not the tiniest bit familiar with programming, I wonder if he meant I should replace “user” for id -u and same thing for groups??

Please help as I am desperate and Apple support’s solutions haven’t helped me so far!!

marked as duplicate by nohillside macos Dec 23 '18 at 19:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • hi, did you try to log in as different user – Ruskes Nov 2 '18 at 20:55
  • yes, I’ve tried all the primary options (e.g. logging in ss different user, restarting the computer, FirstAid, etc) that’s why now the last option seems to be typing commands on Terminal ( on recovery mode ). – L. Lacerda Nov 2 '18 at 20:59
  • can we have a screen shot of the error message ! did you release the SIP inhibitor ? can we have some console logs to see what is going on – Ruskes Nov 2 '18 at 21:09
  • I tried uploading a picture but it won’t load. However if you type “macOS needs to repair your library loop” on google images the first few pictures that have a “User Name” and “Password” with a lock next to it, that is exactly what it looks like. – L. Lacerda Nov 2 '18 at 21:18
  • I’ve been thinking of Re-installing the new OS Mojave, but I’m afraid it’ll worsen my problem because I have little memory. – L. Lacerda Nov 2 '18 at 21:30


That’s the link that should help. Worked for me. I’d been frustrated by this problem for weeks. Disk utility repair was not good enough. But resetting user permissions as per above link did the trick.

Not the answer you're looking for? Browse other questions tagged .