1

I've inherited a previously used and configured MacBook Pro with Mojave (10.14.1) installed on it. I'm trying to navigate the system using the terminal but the tilde character ('~') doesn't work! Instead, what I believe to be a superscript ('˜') version of the tilde appears when I hit shift + '`'. What could be causing this, and how can I get back the default, expected behaviour ?

1

After going through all the keyboard settings, it turns out that there is a difference between 'US' and 'US International PC'. The bizarre tilde behaviour was part of the 'US International PC' keyboard configuration.

| improve this answer | |
  • 1
    Yes, US International PC is a special layout, taken from Windows, where tilde and certain other keys (` ^ ' ") serve as dead keys to create the most common accented characters in European languages. But you can always get the non-accent version by typing space after the deadkey. – Tom Gewecke Nov 2 '18 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .