2

I'm currently a new Mac user, I was given a newer iMac to test with High Sierra installed on it, I needed to install Mojave to use the app I need.

It seems to be stuck at 2 minutes remaining for the last 2 hours. When I look at the activity monitor, it has already received 97 gigabytes of data on the network tab, should I be worried?

Mojave Install Activity Monitor

1

Turns out, something on our network, who knows why, was blocking some aspect of the OS update. As soon as I moved the PC to an external line, the update completed in about 40 minutes.

0

I have run into similar situations with previous OS installs on other Macs. And after several hour with the installer saying ___ minutes remaining I finally gave up and held down the power button till the system shut off.

Upon powering up it finished the install process and went through the new OS post-install screens that ask to verify settings, iCloud, etc. And left me at the login screen, which worked fine.

HOWEVER I hope you have a backup in case my use-case scenario was atypical. So proceed at your own risk. But honestly you don't have much choice. The system is likely hung on something that could never time-out. So you really don't have another choice, you'll have to power cycle the Mac and hope for the best.

  • As there's a Cancel button & the System appears to currently be responsive, I'd give that a go first before going for the big off switch. – Tetsujin Nov 2 '18 at 16:08
  • Thanks guys. How long should an install like this typically take? – Fexception Nov 2 '18 at 16:22
  • It depends heavily on the Mac, how fast it is and how fast your network connection is. For me it is usually 1 to 2 hours – Steve Chambers Nov 2 '18 at 17:46
  • Didn't help. It shows me a blinking folder with question mark in it. Tried installing again and after many hours it errored out again at 2 minutes remaining. – Omar Rehman Dec 19 '18 at 23:17
  • Boot into recovery mode, reformat the HD, then run first aid, 2 - 3 times. If it keeps failing the same way I would blame the HD/SSD in the unit. – Steve Chambers Dec 20 '18 at 1:36
0

I saw this same issue with my Mac Mini and resolved it by removing one stick of RAM.

Sounds bizarre, I know, but I tried several things to resolve the issue and after 7-8 tries it was finally removing that extra stick that did it.

In my case it may have been because my Mac Mini was refurbished and the two sticks of RAM in it were from different manufacturers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .