0

I'm a "keyboard-oriented" user. I normally switches between applications via Command+Tab combo. I noticed the following issue when working with a Linux guest (steps to reproduce):

  1. Run a Linux VM in Single Window mode.

  2. Switch focus to another Mac application window such as Chrome browser.

  3. Switch focus back to the VM via Command+Tab.

At the point, it looks like the VM has been focused, but it seems actually only the VM window is focused, but not the running VM itself. I'm saying this because at this point:

  • Command+H combo still hides the VM window. It's not sent inside the VM itself. Note I have unchecked the shortcut in "Keyboard & Mouse > some_profile > Edit Profile > Keyboard & Mouse > Fusion Shortcuts > Hide Application".

  • Command+M combo still minimizes the VM window, having unchecked the relevant shortcut as above.

  • Typing "Space" key is not sent in the VM.

  • Not until typing some "normal" keys, such like alphanumeric keys, does the focus actually move inside the VM itself.

This focusing issue does not happen when the VM window body is focused by mouse pointer. Actually it does happen if the window is focused by explicitly clicking VM window title bar, but not the window body.

Is this a bug or what config change is needed (e.g., keyboard settings)? Essentially, what I want is Command+Tab able to switch right inside the VM, but not at the VM window.

  • Try pinning it to a different Space instead, then key-command to switch Spaces. That should bring it to the font correctly. [Works with Parallels & both Apple & MS Remote Desktop, not tested VMWare] – Tetsujin Nov 2 '18 at 11:38
  • @Tetsujin It works. But sorry it's not what I'm after. In real use, I will have VM window and browser window opened side by side, and need to constantly switch between the two. So as long as there is another window in the same workspace except for VM window, it's gonna be a problem. – Naitree Nov 2 '18 at 11:55
1

I'm a keyboard user as well and I had this same exact problem. I don't have a perfect fix, e.g. a setting you can change. However, I do have a pretty good workaround.

After switching to the desktop with your Windows VM by using your keyboard shortcut, just hit an extra arrow key. For me, I type "command-control-right" to get to the space to the right, then I let up the "command-control" and just type "right". From there, I can type "command" to bring up the Windows start menu.

This seems to work regardless of what application is in the foreground on the Windows VM. The main problem with this technique (other than the extra keypress) is that it does send an "arrow" event to the foreground application. For me, that's usually pretty harmless. Like I said, it's not perfect.

HTH.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .