This is the same/similar to this one, but I'm running the final version of 10.14.1. I can make the problem go away if I remove the following files from /Library/Preferences/SystemConfiguration/:

  • com.apple.airport.preferences.plist
  • com.apple.wifi.message-tracer.plist
  • NetworkInterfaces.plist
  • preferences.plist

After a reboot, the captive login window works, but at some point, it stops working again and looks like: captive login window error

I haven't tested much - I don't have regular access to many captive Wi-Fi networks.

I can work around the problem by dismissing the error, closing the window and using Safari to go to https://captive.apple.com, but I would like to solve the problem rather than work around it if possible.

Has anyone figured this out or can anyone point me in the right direction?


It may be related to the Sophos antivirus scanner, see https://support.home.sophos.com/hc/en-us/articles/360020126572-Captive-Portal-Login-Page-does-not-load-on-MacOS-when-connecting-to-a-Public-Guest-Wi-Fi-Hotspot-

  • Answers should be more than just a link; links can break and render your answer useless. Please summarize the essential part of the referred page into your post. – nohillside Jan 28 '19 at 15:31

I have seen the same thing on our network, also have a few iOS devices having almost the same problem.

I opened a ticket with Cisco this morning, they stated that they have other tickets open with the same problem (all Mojave or iOS12). Seems like Apple may have changed something on the captive.apple.com site with the way it works.

Cisco is gathering information, I may open a ticket with Apple as well.


As a workaround, you could navigate to captive.apple.com/hotspot-detect and the browser should return the Wifi login screen. I'm having the same issue and it works for me.


Removing the custom DNS servers entry from Network preferences resolved the issue for me.


Also, check the DNS setting as suggested here, which worked for me:

Open System Preferences -> Network -> Wifi -> Advanced -> DNS.

In the DNS section, remove all the DNS addresses and search domains and apply the new settings, so that the public wifi could use the one that it is configured with.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .