I have a 320GB harddrive with 95GB free. I boot to a 10.5 disk, open disk utility, and add a 40GB partition. Halfway through the progress bar, though, it tells me that there's not enough space. I'm not sure what it means- I'm just splitting my free space off to another partition- it shouldn't need any extra space.

Any ideas as to how I can partition my drive?

Clarification: this is my laptop's internal drive- the one I boot from. I can't boot normally and partition with /Applications/Utilities/Disk Utility.app.

4 Answers 4


Ok, solution found on an old superuser question, posting here for posterity.

I just needed to defrag the thing

I got Coriolis iDefrag. I ran that on the compact setting (required restarting into it's own special mode, but no disk burning was needed). A few hours later I tried to resize the partition and it worked fine.


Assuming you're booting from the install disk and not your boot volume:

Try making the new partition even smaller the first time... like 20 GB. If it completes successfully, you can usually go back and resize the main partition again to a smaller size. So the second time, you would delete the new partition and add the final 40GB partition (shrinking the boot partition by an additional 20GB). Not sure why this happens, but I'm usually able to do it this way.


You may be getting the 'not enough space' error since there isn't enough space to hold some files while the reformat is going on. I think to be able to do the format like this, you would have to have at least another 125GB free (to basically store all the other data you are currently using)


Wipe free space, and then try repartitioning. I'm sure that's all the defrag did that mattered.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .