6

When I originally downloaded the Install macOS Mojave.app for the original release 14.0.22, I got a 6.03 gig file.

Today I replaced that file by downloading the installer fresh from the App Store for 14.1.0. The app is only 22 megs! So obviously this is just a shell that I imagine downloads the needed content over the internet at runtime.

But I need an offline installer, for clean-installs on various Macs and for creating virtual machines.

➥ How to obtain fully-loaded offline installer app for Mojave 14.1.x?

What about just using the original installer, then updating immediately the newly installed OS to .1? That .1 update was a whopper, over 3 gigs! I really want to avoid repeating that updater download. I really need a fully-loaded offline installer.

enter image description here

  • 1
    When I go to re-download Mojave from the App Store on a Mac already running 14.1 I get a full 6GB download. Might be worth trying again. – Mike Scott Nov 1 '18 at 7:52
  • 1
    @MikeScott How did you manage to download the installer? When I visit the App Store page of macOS Mohave and click on Get, System Preferences app is launched with Software Update pane opened. – Nimesh Neema Nov 1 '18 at 9:31
  • @NimeshNeema Yes, that happens for me too, but then the 6GB download starts in the Software Update pane. – Mike Scott Nov 1 '18 at 10:03
  • @MikeScott I tried the download again. Same result, little 22 meg app. That app launches, and walks through the Wizard steps, confirming license terms etc. – Basil Bourque Nov 2 '18 at 5:00
4

The 22 MB "stub" installer is downloaded when your Mac is having trouble getting the correct data from Apple's software update catalogs. This is quote common during the first 24 hours or so, as it takes a little while for the updates to propagate across the CDNs. The solution in this case is to delete the stub, wait a couple of hours, and then try again.

There is also a useful script by Greg Neagle that lets you inspect which installers are available in your update catalogs, and can download them for you: installinstallmacos.py

PS: If you have a Mac managed by an organization, you may also get the stub installer if your administrator hasn't approved the new update, e.g. with Reposado.

  • 1
    FYI, I am still getting the 22.8 meg stub at least 5 days after 10.14.1 release. – Basil Bourque Nov 6 '18 at 23:21
  • FYI I am getting the stub installer almost 6 MONTHS after release. – Michael Apr 29 at 19:25
  • There is a more powerful version of Greg's code available at github.com/grahampugh/macadmin-scripts I forked that script to add support for one of my macbooks running 10.12 github.com/julianharty/macadmin-scripts Note: the script is designed to run on the machine it's intended to upgrade. – JulianHarty Dec 1 at 17:48
0

You can easily download the full 14.1.0 installer using this tool: macOS Mojave Patcher Tool.

Start the tool, and then go to Tools > Download macOS Mojave... and select a download location.

After the download is complete, it will ask you if you want to create a patched usb installer, simply click Not Now as you don't need a patch (except if you want to install on a very old mac). You can safely quit and remove the tool, as you no longer need it.

Here you are:

  • I got macOS Mojave Patcher quit unexpectedly. error after a short period, how to fix that? – Mustafa Magdy Feb 24 at 11:36
  • 4
    This is ridiculous. Why should I need to download an untrusted application for what should be a simple wget?:?? – Michael Apr 29 at 19:26
  • Wget is not simple it is a command line tool. Most Mac users don't use the Terminal (and going back pre OSX Macs did not have a Terminal it is not the Apple way) – user151019 Apr 29 at 20:05
-3

Here you can download all macOS Installers including macOS Mojave, Try to use a download manager, The links are resumable.

  • Thanks for the idea, but I could only consider running an OS installer provided by Apple directly, because of security risks. – Basil Bourque Mar 25 at 5:00
  • Apple Installers are digitally signed it means if something is tampered in code, Application itself will not execute, so it is all safe. – The KingMaker Mar 26 at 6:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .