1

So, I've spent many hours trying to work an issue out with missing disk space after "uninstalling" Bootcamp on my c. 2014 500GB Macbook Air. I've consulted many of the posts on SE, some of which helped significantly, but after reinstalling the OS (10.14.1) from Internet Recovery mode the disk space is still not available (but I can see where it is I think!).

I am essentially wanting to know if there's a way to recover, merge or resize my disks (will provide terminal output below). I'm pretty sure the file system is now fairly confused, and trying to unravel this is somewhat outside of my level of expertise.

Here's an abridged overview of what I've done so far.

  1. Installed Bootcamp in 2017 (partitioned the 500GB HDD to 250GB for Mac and 250GB for Windows). When I uninstalled I don't think I used the Bootcamp uninstaller (my bad).
  2. After uninstalling I was left with the 250GB Mac HDD and was "missing" 250GB).
  3. This week I tried to i) identify where the missing space was, and ii) recover the missing space (merging it into the Mac space).
  4. I finally came across a post on AskDifferent suggesting that I turn on FileVault, and then boot to Internet recovery. After I did this I found the missing space (it appeared after the Recovery partition on /dev/disk20 or something).
  5. I spent several hours last night unmounting disks, unlocking the encrypted disk, unencrypting, using GPT to delete unused partitions etc. following previous posts.
  6. I opened disk utility and could see that the Macintosh HDD was on /dev/disk0 and the missing space was on /dev/disk20 (virtual) - I figured after reinstalling the OS that I'd have access to all of the space, but was mistaken. After reinstalling OS Mojave, I still only have the 250GB. The other 250GB seems to be residing on the internal virtual ("synthesized") disk.

Here's the output of diskutil list after the new install of OS Mojave last night:

/dev/disk0 (internal, physical):
#:                       TYPE NAME                    SIZE       
IDENTIFIER
0:      GUID_partition_scheme                        *251.0 GB   disk0
1:                        EFI EFI                     209.7 MB   disk0s1
2:                 Apple_APFS Container disk1         250.8 GB   disk0s2

/dev/disk1 (synthesized):
#:                       TYPE NAME                    SIZE       
IDENTIFIER
0:      APFS Container Scheme -                      +250.8 GB   disk1
                              Physical Store disk0s2
1:                APFS Volume Macintosh HD            46.8 GB    disk1s1
2:                APFS Volume Preboot                 44.7 MB    disk1s2
3:                APFS Volume Recovery                512.8 MB   disk1s3
4:                APFS Volume VM                      2.1 GB     disk1s4

And of df -h:

Filesystem      Size   Used  Avail Capacity iused               ifree

/dev/disk1s1   234Gi   43Gi  187Gi    19%  544593 9223372036854231214
devfs          185Ki  185Ki    0Bi   100%     639                   0
/dev/disk1s4   234Gi  2.0Gi  187Gi     2%       2 9223372036854775805
map -hosts       0Bi    0Bi    0Bi   100%       0                   0
map auto_home    0Bi    0Bi    0Bi   100%       0                   0

I'm wondering if /dev/disk1s4 is where the "free space" is? (it's mount point it /private/var/vm).

Having spent hours reinstalling the OS, I'd ideally like to see if there's a fix to this issue that doesn't require a full rewrite.

If more into is needed, let me know and I'll happily add to the post.

Thanks in advance to anyone that can help!

Matt

You must log in to answer this question.

Browse other questions tagged .