2

I am moving from Mac Office 2011 to Office 365. After running the uninstaller, An invisible file in the Excel package, Microsoft Office > Microsoft Excel > Contents > Resources > En.lproj > Help > Art > wheel, continues to show “in use” despite several restarts, so I cannot empty it from the trash. My UNIX skills are embryonic at best. How do I kill this file?

  • 2
    Have you tried rebooting in Safe Mode? That turns off pretty much all 3rd-party background processes. – Steve Chambers Oct 30 '18 at 15:28
  • Maybe ... use 'sudo rm -rf ~/.Trash' to delete it without Finder doing the in-use thing. Then reboot and (I hope) the interfering process won't be able to find the problem file. – WGroleau Oct 30 '18 at 16:43
  • Safe mode and sudo rm -rf were not helpful, alas. Thanks for the suggestions! – Ken Franklin Oct 31 '18 at 21:49
1

If sudo rm didn't delete it, then maybe it somehow got the schg flag set?

You could try this:

    sudo chflags noschg /Users/bob/.Trash/nasty.file.ext

    sudo /bin/rm -f /Users/bob/.Trash/nasty.file.ext

As I mentioned in the comments, you could also try moving the file to /tmp/ and rebooting, since that usually clears out the /tmp/ but I have a sneaking suspicion that isn't going to help in this case.

0

Move (don't copy) that file to your desktop. Then reboot. Whatever process is looking for it, shouldn't be able to find it. Then you should be able to delete it from your desktop and finish the Uninstall process.

  • This makes no sense. If it can "find" the file in the trash (which is certainly not where it originally was), it can find it on the desktop. Now, if you had said "Move it to /tmp and then reboot" that might have helped, since /tmp/ is cleaned out by rebooting. – TJ Luoma Oct 30 '18 at 16:52
-1

I will assume that you have no files that you need in your Trash (because why else would they be there?)

(I am assuming this is your own Mac and that you have an admin account, if that is not the case, please let us know).

Launch Terminal.app and enter this command:

sudo rm -rfv ~/.Trash/*

Be very careful: sudo rm -rfv is just about the most dangerous command there is.

You will be prompted to enter your administrator password.

Enter it when prompted (it will not appear in Terminal when you type it).

  • Ah, the ol' down-vote with no explanation. Stack Exchange at its bëst. 👍 Don't let the fact that this is the most-likely-to-work solution dissuade you. – TJ Luoma Oct 30 '18 at 16:51
  • Alas, TJ, It did not remove the file. – Ken Franklin Oct 31 '18 at 21:50
  • That's truly odd. a) What error did it produce, if any? b) Have you tried moving the file to /tmp/ and then rebooting? /tmp/ is usually cleared out on reboot, but if this file is that "sticky" it might not work for it. – TJ Luoma Nov 1 '18 at 0:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .