0

I have 2 @ 4TB drives in an 8tb Raid 0 stripe enclosure that has become corrupted. I have tried to repair the volume via, disk utility, terminal and single user mode with no luck. All 3rd party software seem to only offer recovering as an option. I am hoping there is still some way I can repair this drive. Please let me know.

The message I receive is as follows:

Checking Journaled HFS Plus volume
Checking extents overflow file
Checking catalog file
Incorrect number of thread records
Checking multi-linked files
Checking catalog hierarchy
Invalid volume directory count
(It should be 423 instead of 420)
Invalid volume file count
(It should be 14859 instead of 11142)
Checking extended attributes file
Checking volume bitmap
Checking volume information
The volume EU8TB could not be repaired after 3 attempts
File system check exit code is 8
Restoring the original state found as unmounted
Error: -69845: File system verify or repair failed
Underlying error: 8: Exec format error

I took a screen shot of orphaned files being fixed under single user mode.

enter image description here

1

First - take a backup of your file system. Even though it is already corrupted, it is possible to further corrupt it by trying to fix it. Make sure you have a copy before this.

Then I would suggest simply trying multiple times to check and fix the file system in single-user mode. It sounds counterintuitive, but really you sometimes need to do this multiple times to clear all errors.

You would run a check like this:

fsck -fy

Note that even though you're "repairing" the file system, it is really just fixing data structures to be internally consistent. You might (and probably will) loose data and files in the process.

As you have a RAID-0 drive, there's no redundancy in the RAID that can help you rebuild the drives while keeping all your data intact. If the data on the drive is important enough for you that you won't be happy if you loose it, then you shouldn't run RAID-0 - but rather a RAID-level with redundancy. And always create backups!

  • Thank you? The raid stripe shows up as disk4. So would I run fsck -fy /dev/disk4 ? also what is the difference between /sbin/fsck and fsck without it? – Raman Dooman Oct 30 '18 at 15:54
  • Yes, that’s the way to specify the disk you want. There’s no difference with or without sbin. If your PATH allows it, it is just a shorthand to write it without. – jksoegaard Oct 30 '18 at 17:25
  • i tried fsck -fy /dev/disk4 – Raman Dooman Oct 31 '18 at 1:20
  • I received the following message: fsck usage: fsck [ -dnypq] [-l number] – Raman Dooman Oct 31 '18 at 1:21
  • thats beyond my scope of understanding – Raman Dooman Oct 31 '18 at 1:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .