3

I installed a new SSD (Transcend JetDrive 850) on my MacBook Air 7,1. I was starting the internet recovery using Option-R, and Disk Utility was not detecting my new SSD. When I’m doing an internet recovery with Option-Command-R, Disk Utility is finding my new SSD but I’m not able to either recover the data from Time Machine, neither install Mojave.

When I’m running Internet recovery using Option-R, the proposed OS is El Capitan but I’m not able to install the OS because my SSD is not found,but I was able to install it on USB flash drive.

I’m wondering if the only solution to this problem is to install this new ssd in an USB enclosure, run internet recovery with Option-R, install El Capitan on it, the same way I did on my USB drive and then reinstall the ssd in the Mac...

Thanks for your help

2
  1. Start recovery mode with CommandOptionR.
  2. Open Terminal, and run below commands:

    diskutil list
    
  3. Find which /dev/diskX is yours, usually disk0. Once you identify your disk, erase it with diskutil

    diskutil eraseDisk JHFS+ MacOS /dev/disk0
    

After this, I was able to restore using Time Machine and even install Mojave, giving me an option to chose internal transcend drive for install

After erasing disk using Disk Utility, Time Machine nor Mojave install was working. Mojave was showing my internal Transcend drive greyed out, but this worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .