1

I have been using my macbook pro since 2013. Around early 2017 I got a 275gb crucial ssd and installed it. It was working fine until about a month ago my macbook would no longer turn on. Took it to the repair store and they told me the motherboard had to be replaced. After replacing the motherboard my mac no longer uses my ssd to start up. After starting in internet recovery mode I looked at disc utility. My macbook recognizes my ssd, and it even passes verify/repair checks. However it will not let me mount it. After pulling up the command line and running:

diskutil list

I see:

/dev/disc0
    #:         TYPE NAME                            SIZE       IDENTIFIER
    0:       GUID_PARTITION_SCHEME                  *275.1 GB    disc0
    1:       EFI                                    209.7 MB     disc0s1
    2:       7C3457EF-0000-11AA-AA11-00306543ECAC   274.9 GB     disc0s2

as well as a few other discs that seem to be other local storages (all < 600KB)

I have tried running

mount /dev/disc0

and gotten

mount: /dev/disc0: unknown special file or file system.

when i run:

mount force /dev/disc0

i get:

mount: you must specify a filesystem type with -t.

So finally I try:

mount force -t /dev/disc0 and mount -t force /dev/disc0

and both return what seems to be a verbose/usage instruction message

Any ideas on what else i can do to get this disc to mount? It worked fine with the other motherboard! I'd like to avoid wiping it if i can but I am really not opposed to it as I backup most of my files to an external hard drive every now and then

  • how much was the Logic board replacement – Ruskes Oct 27 '18 at 22:25
1

Which part of the

mount: /dev/disc0: unknown special file or file system do you not understand.

7C3457EF-0000-11AA-AA11-00306543ECAC is unknown disk format it should be Apple_APFS or Apple_HFS

Hope you have a back up and can reformat the disk.

  • Well now that I know I need to wipe it, which format is used in what circumstance? – skyleguy Oct 28 '18 at 1:45
  • High Sierra and up uses APFS – Ruskes Oct 28 '18 at 1:52
  • Thanks! Guess it’s time to wipe it. Will be back to say whether it works or not – skyleguy Oct 28 '18 at 13:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .