19

when pairing airpods with a mac, the sound quality is poor due to the fact it also uses them for microphone by default...

when I switch the audio input (microphone to internal), then quality of the airpods sound is excellent.

I don't want to do this step each time I pair airpods, is there a way to make the default microphone for mac is the internal one.

5
  • permanently or temporary
    – Ruskes
    Commented Oct 26, 2018 at 23:07
  • preferably both, kindly provide all solutions you know about if possible, thanks.
    – DeyaEldeen
    Commented Oct 26, 2018 at 23:09
  • FWIW my AirPods use the Internal Mic by default and always sound good. Changing internal mic to AirPods makes the audio terrible.
    – JBallin
    Commented Oct 29, 2018 at 17:32
  • @JBallin what macos are you using? I'm on high sierra,
    – DeyaEldeen
    Commented Oct 29, 2018 at 20:08
  • Latest (Mojave)
    – JBallin
    Commented Oct 29, 2018 at 20:14

7 Answers 7

5

Ok, here is a script that would select Internal Microphone..

Copy Paste following in the Script Editor in Utility folder.

Run it, if you like it we can make it a keyboard short cut.

tell application "System Preferences" to activate
tell application "System Preferences"
    reveal anchor "input" of pane id "com.apple.preference.sound"
end tell

tell application "System Events" to tell process "System Preferences"
    tell table 1 of scroll area 1 of tab group 1 of window 1
        delay 10
        select row 1
        tell application "System Preferences" to quit
    end tell
end tell
5
  • doesn't switch the current source, if the input source is airpods, then it doesn't switch to internal... just opens the panel.
    – DeyaEldeen
    Commented Oct 26, 2018 at 23:30
  • sorry, i was wrong, it works, i changed delay 1 to delay 100, i thought it was milliseconds, .... how to add a shortcut? and is there a way to make this without showing the panels?
    – DeyaEldeen
    Commented Oct 26, 2018 at 23:32
  • 1
    ok to make it close add ` tell application "System Preferences" to quit' after select row
    – Ruskes
    Commented Oct 26, 2018 at 23:53
  • What's the delay for? Commented Jun 9, 2020 at 17:00
  • I found that delay 1 (1 second) works fine -- 10 seconds delay is probably overkill.
    – Jo Liss
    Commented Aug 8, 2021 at 17:06
5

If you're willing to spend $5, get ToothFairy.

Not only does it make it much easier to pair with your Mac, but it has a feature to do exactly what you're asking for under Settings » Advanced:

enter image description here

Check that box at the top and voilà!

UPDATE: ToothFairy is now also part of Setapp.

3

My working solution is:

Open the standard “Audio MIDI Setup.app” utility, and click the "+" at the bottom to create an Aggregate Device. Then select the Internal Microphone as the only component in this aggregate device and select it as the default input. For some reason this prevents Mac OS X from selecting the Bluetooth Microphone from now on and it will stay on the internal one when you reconnect.

After creating that aggregate input, go to your usual System Preferences -> Sound -> Input (tab)

Taken from: How to Force Bluetooth Headphones to Use Internal Microphone in macOS

2
  • Thanks! This should be more upvoted, it actually works seamlessly unlike the other hacks above. Commented Mar 26 at 15:54
  • worked on Sonoma 14.4.1. Thanks
    – GNassro
    Commented Mar 29 at 12:41
0

You can use this program: http://milgra.com/airpods-sound-quality-fixer.html

It's open-source project: https://github.com/milgra/airpodssoundqualityfixer

And it allows you to automatically switch to a built-in MacBook microphone, then you don't have to do anything, after connecting your AirPods to your mac.

Anyway, it should be fixed by Apple, it's ridiculous, to automatically decrease audio quality to such a bad level. And it's not so obvious, to go to settings and change the source of the microphone. In the begging, I was struggling to just recognize why this sounds like a ... so bad

3
  • 1
    Bluetooth has 2 modes, 'headphones' & 'headset (with mic)' - it cannot actually handle full-spectrum audio both directions at once. This is not an Apple failing, it's a Bluetooth failing. Presumably as technology gets faster, this limitation will eventually be mitigated.
    – Tetsujin
    Commented Dec 17, 2020 at 19:33
  • 1
    Of course, it is limited by Bluetooth technology. But there is a choice to get great output (earphones) or great input (microphone) quality. And Apple decided to prioritize microphone quality instead of good audio. And I don't understand it, especially in a case, when I'm using MacBook, which has much better microphone quality than AirPods. So I don't even need to use AirPods microphones, because I have better on my laptop.
    – Skibq
    Commented Dec 18, 2020 at 20:44
  • It IS apple failing. As a user, I totally understand the limitation of Bluetooth and sure we can say it's Bluetooth failing as well. What I don't understand is why isn't there a simple way I could listen to great quality music on AirPods pro. Why doesn't the AirPods or mac OS give me an option of choosing a great sound or a great mic, why does it have to be random, or why it switches midway in the middle of playing music? BTW ToothFairy solved it for me. Commented Oct 5, 2022 at 7:23
0

Nowadays you can also use this Tool for Macs with M1/2/3:

https://github.com/Gaulomatic/AirPodsSanity

It automatically switches to a defined input source.

If you have trouble running it check in Settings/Privacy and allow it to run.

-1

I am using Mac High Sierra (10.13.6). Here is another suggestion suggested by a user at http://ssrubin.com/posts/fixing-macos-bluetooth-headphone-audio-quality-issues-with-hammerspoon.html#comment-4018174387:

"Hi, I found another way to "fix" this without using scripts or apps. Open the standard "Audio MIDI Setup.app" utility, and click the + at the bottom to create an Aggregate Device. Then select the Internal Microphone as the only component in this aggregate device and select it as the default input."

0
-2

This is because you opened some app in the background that consistently uses your microphone while you are playing audio in other apps. Check what app or tab is using the input and shut it down. Then, the quality will be excellent even if the input is still your Airpods, which is the default setting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .