1

After I formatted my disk (instead of just erasing the volume), I struggled to reinstall Mac OS 10.11 (El Capitan) on my early-2009 Mac Mini (10.11 being the latest supported version.)

I tried physically removing the disk and installed a bootable installer on it, following the Apple guide "How to create a bootable installer for macOS". When I tried to install the OS this way, the OS 10.11 installer started fine, but just before the actual install procedures commenced, it gave the error: "Volume contains an OS X installation which may be damaged".

I subsequently tried installing the OS from a USB drive instead of from the disk itself. Unfortunately, I got the same error.

What would cause this error, and what would be a good way to resolve it?

  • I have not find the answer on Ask Different, but sources I found on the Internet suggest that booting from USB would cause it, or that the El Capitan installed is expired. For completeness: I downloaded El Capitan today using the "download previous purchases" trick from the App Store. I'm unclear if that it the older 10.11.0, or a newer 10.11.6. – MacFreek Oct 26 '18 at 21:00
  • 1
    After booting from the USB flash drive, did you use the Disk Utility to completely erase the drive where you intend to install El Capitan? – David Anderson Oct 27 '18 at 4:04
  • @David Anderson, good question. I did repartition the hard disk, but not the USB drive. – MacFreek Oct 28 '18 at 20:01
1

In the mean time, I proceeded with a work-around: install Snow Leopard (10.6) on the disk, using a DVD and external DVD drive. From there on, I'll upgrade to 10.11. Keeps me busy, and it seems to work (so far). However, I consider this a work-around, not the solution to this question.

  • Did you manage to get to 10.11 using this procedure ? I'm back to 10.9 and will try when it downloads. – Niloct Dec 18 '18 at 17:05
  • I did it. The hint that you can't install over a USB which is running the installer is very important! – Niloct Dec 19 '18 at 3:14
  • It did work for me, albeit with a few caveats: I had to run all upgrades for 10.6 (and check no new updates were found) before I could run the App Store to upgrade to 10.11. Also, 2FA in the app store required to append my password with the one-time nonce for it to work. After that, it was a smooth ride. – MacFreek Dec 19 '18 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .