3

I updated to Mojave yesterday and since then I get so many windows prompting up with the message “SIMBLAgent.app“ wants access to control... and I can get rid of all those windows comming.

Someone knows how to stop that?, any help is appreciated

  • 2
    Simbl is code that injects into apps especially safari to add extra functionality it is not an apple app so you must have installed it – user151019 Oct 26 '18 at 8:50
  • it just come up after upgrading to Mojave, I did install nothing. – Francisco Oct 26 '18 at 8:51
  • 1
    It installs some things in /Library/Application Support/SIMBL - and i would have been installed by an admin on your machine before Mojave. Mojave has changed security so now causes these windows – user151019 Oct 26 '18 at 9:30
  • 1
    The app is described in en.wikipedia.org/wiki/SIMBL – user151019 Oct 26 '18 at 9:31
  • See this post on this site about what SIMBL is. The accepted answer may give you a clue as to where to find the app. – IconDaemon Oct 26 '18 at 12:15
4

These messages are part of the new security measures in Mojave. You are giving up control of your system to apps you may not intend, so you should deny those requests until you’re sure it is not malware or something you don’t want typing / interacting on your behalf.

Consider, an app could copy text like passwords or just watch for you typing / save screen captures using these permissions. Not all do, but you might use caution before disabling security.

You can try giving the app full disk access in the System Preferences.app > Security & Privacy > Privacy > Full Disk Access. Add the application by using the [+] icon or by dragging to the list.

Mojave Full Disk Access

  • which app should I give access? is it SIMBLA an app?, if yes I do not find it when using the [+] icon on that preferences... – Francisco Oct 26 '18 at 8:20
  • On my computer SIMBLAgent.app can be found on Automation. Asking control for any service (even screen capture) ! – Joseph Merdrignac Oct 29 '18 at 9:35
1

As per Gummibando's answer, you'll need to give permissions to SIMBLAgent.app in Security & Privacy in preferences:

The full path to the app should be:

/Library/Application Support/SIMBL/SIMBLAgent.app

However, it appears Automation is the correct category: SIMBLAgent.app Security Automation Prefs

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .