1

I am struggling with the same issue raised here - "Unable to verify account name or password" on outlook.com Exchange server (browser works). It started after I updated MacOS to Mojave this week. For me everything worked fine (even after upgrading the OS) until the first restart. At that point Mail started complaining it could not verify my credentials.

Here's what I've tried so far:

  1. Confirmed my credentials still work with my @hotmail.com/Office 365 account.

  2. Created a new user on my MacBook Pro and tried to connect to the account as an Exchange account.

  3. Reset my keychain.

  4. Reinstalled Mojave.

  5. Changed my Office 365 password.

  6. Tried every esoteric solution reported on the internet that I could find.

I was able to connect Mail to my hotmail account by adding it in as an IMAP account. However, this only works for Mail and not for the calendar and contacts.

Any help in trying to find a solution would be greatly appreciated.

3
  • did you try... Depending on how the server is configured, you may need to include your DOMAIN in the username field. It could be username@domain or domain/username. – Ruskes Oct 24 '18 at 20:11
  • It also used to need you to uncheck "automatically manage connection settings" in both incoming & outgoing account prefs. Haven't tested in a while, but I still have mine set that way & no issues in Mojave. – Tetsujin Oct 25 '18 at 6:25
  • Just to follow up on this issue. After the upgrade I wasn't able to add my account for about a week or so. I even opened up an issue with Apple, but didn't hear back with a solution. However, after waiting a while I tried again and was successful in adding my account again without issues. I have no idea what the issue was, or why it corrected itself. – Matt Wenger Dec 10 '18 at 0:07
1

I've had this same problem for months on Sierra. Posted my solution re: needing to generate an "app password" here: "Unable to verify account name or password" on outlook.com Exchange server (browser works)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .