35

I'm running MacOS Mojave on a 13" Macbook pro with a 4K external monitor (scaled to 2560 x 1440).

When running two apps in split full screen mode it won't let me reposition the "split" which controls the share of the screen of the two apps by grabbing the vertical bar.

This behaviour can be seem in this screen recording.

Any ideas on how to solve this? Or is this just a bug that needs fixing?

  • what apps are you running ? – Ruskes Oct 24 '18 at 20:20
  • I do not see you moving the separator bar in the middle of the screen – Ruskes Oct 24 '18 at 20:22
  • 2
    @Buscar웃 in this case firefox and iterm2, but the issue happens regardless of the apps used. I'm not moving the separator bar because it wont let me. When clicking and dragging it the bar remains. – harryg Oct 25 '18 at 8:09
  • 1
    I took the liberty of creating a discussion in macOS Mojave community about this: discussions.apple.com/message/34106080 – eduludi Nov 2 '18 at 8:11
  • 3
    macOS Mojave 10.14.3 and this issue still remains. – Sajib Acharya Mar 28 at 22:50
44

WORKAROUND: Read somewhere that to get (temporarily) the resizing bar, you drag one of the split windows by the title to the other side of the monitor. The bar will remain for a while. Resize, and if needed, switch back the windows. It has been working for me on an external LG monitor in Mojave.

  • 1
    Just wanted to point out that this answer works consistently (especially with multiple displays and splits). Thanks! – LeslieOA Mar 20 at 13:48
  • 1
    can also confirm this works – harryg Mar 29 at 9:19
2

I have the same issue… I’m working around it by resizing the windows in split view on the MacBook screen and only then dragging them to the external monitor, but this "solution" is obviously far from perfect :/ Hope they fix this soon.

1

I found that if you simply click the title bar you'll be able to drag the windows after, for a few seconds.

I believe that this is intentional to prevent changes to the screen split by mistake.

So it's possible that this is by design.

0

Workaround: When putting things into full screen, don't put anything full screen instead hold the green expand button on the top left, wait until a side turns blue, than select side, select your second app, now you have a bar in the middle you can drag left/right.

0

enter image description here

  • split the window in your computer screen (desktop 1)
  • resize them as you want
  • Zoom out (using your 4 fingers on the pad) to see all the desktops (windows).
  • pick, drag your window from your computer and drop it to the external monitor
0

This just happened to me....

I got out of it by doing a three finger swipe up the mousepad This takes you to a view where you can see all spaces at once Then hover over the space with the expanded app - it will give you an option to minimize it. Click that.

enter image description here

0

This is an annoying bug that I have reported to apple numerous times.

The best workaround I have found is to move your mouse to the top of the screen to bring down the title bar, and then click on the title bar.

You have to play around and try the title bar for each window. One of them will bring up the resizing indicator temporarily.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .