56

Has anyone else noticed that Chrome refuses to quit instantly when using CmdQ?

Happens with one or several tabs open...

All the other apps I run can be ended by typing / tapping briefly CmdQ, but Chrome insists that I have to hold for an appreciable period of time.

This is becoming annoying, any ideas?

77

This is a change - Chrome thinks this is correct default behavior and shipped this enabled.

  • You can double press the Q - hold command and press and release Q twice as quickly as you are comfortable - Q Q
  • Or change the default to match your expectations and all other programs - see below to change the default setting

Select Chrome in the menu bar and select to un-check Warn before Quitting (⌘Q)

Chrome main menu screenshot

This can also be found in Chrome's Preferences (Cmd,), in the Appearance section:

Chrome Preferences - Appearance

  • 16
    Thank you! Having to hold the key down has been driving me crazy. – braitsch Oct 29 '18 at 21:54
  • 19
    You can report this content all you like. But the product manager for Chrome for Mac should be fired for making this violation of Apple's user interface guidelines default behavior in Chrome. It is horrible. – ctpenrose Nov 20 '18 at 23:48
  • 2
    The command to quit and to close are so close together, some people mistakenly hit Q instead of W and lose web app data. If Chrome doesn't have windows open, it will quit instantly but if you have windows open, you would need to hold down to quit Chrome unless you disable it. – netrox Dec 1 '18 at 2:43
  • @netrox people can use the cmd+shift+t shortcut, or go trough the menu, to get all their pages and tabs back. This really is a non issue and google is just being annoying imo. – Tim Wachter Dec 4 '18 at 14:13
  • If you're interested in the history behind this weird design decision, check out the infamous issue 147 - bugs.chromium.org/p/chromium/issues/… The "we know best" attitude of the Chromium devs in that thread put me off using Chrome for a long time. – Simon Jan 10 at 13:09
3

Still happy with the answer given, but I did find out, by accident, that if you hold command and do a double tap on Q it quits instantly in spite of that option being selected.

Only found out as I have to quit chrome on computers in the lab often...

-2

This happens when you have multiple tabs open. Chrome takes its time to close tabs individually. The best way to save you time is to either close unnecessary tabs or use an app called "Onetab" which automatically closes your tabs and saves them all in one tab. After that, if you command q, it'll work better. Hope this helped you.

  • Thanks for answering, I have tried this with one or several tabs open and its behaviour is the same whether one or 4... Am about to go off and find "Onetab"... – Solar Mike Oct 24 '18 at 7:03
  • 6
    Kelly Choi that's not really the cause of the issue, as stated in the other answer – Luciano Oct 26 '18 at 15:30
  • Not for me either, open a new chrome, single pane single window and no tabs, you have to double press Q to get it to quit or fiddle with the default preference to change this back. – bmike Jun 5 at 10:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .