1

I decided to change my admin name. I went to "System Preferences"-> "Users & Groups" -> unlocked -> changed admin name.

After I rebooted my Mac, it seemed that Admin name hasn't changed. In Finder under "Users", I would still see only my old username. So I went into System Preferences again, but this time I would not be able to unlock.

Upon unlocking, it would show me a login menu WITHOUT username. Neither old nor new username works with the password (that remained unchanged). So basically I couldn't use my admin rights anymore.

Then I tried changing my password. Surprisingly, it seemed to work - the system accepted my old password and new password.

However I still cannot log in as admin. Whenever I press on the lock icon in Users & Groups, neither username/password combination works.

  • confused..what are you logging in as in if not admin. and make sure your caps- lock is not on, or was it on when you changed ? – Ruskes Oct 23 '18 at 17:10
  • I am logging as admin. I do not lock my mac (home use only), so that is not an issue. However for any special cases, that require admin password, I am not able to do anything. The funny nuance is, I tried to change password back and forth yesterday, and it did work. I think the whole problem is in that unfortunate try to change admin user name. It didn't change to the new one and the old one doesn't work either. – Artjoms Smirnovs Oct 24 '18 at 7:05
  • create new admin account – Ruskes Oct 24 '18 at 7:18

You must log in to answer this question.

Browse other questions tagged .