2

I tried to enlarge the bootcamp windows 10 partition by 17gb. I went to disk utility on my mac, resized the mac's partition to smaller leaving 17-18gb of free space, then booted up the windows in bootcamp mode, started easyus partition master. I saw the 17-18gb partition (the only one of that size), wiped it and tried to merge it with the windows partition. EasyUs informed me that the system needs to restart to make these changes. The restart failed 2 times (windows crashed) and finally booted successfully the third time. The partition hasn't change the size. I tried to boot into my macOS to see what is the current structure but it doesn't appear among the bootable Operating Systems after restarting and hiting alt.

My question is similar to this one but I don't seem to have a HFS recovery volume visible. I tried to fix it with gdisk but since I can't find the Recovery HD volume I can't set its GUID nor its properties.

disk configuration shown in diskpart utility

The partitions in EasyUS- the largest one is the MacOS 353,9 gb:

enter image description here

What do I need to do in order to get my beloved macOS back? I have a backup but it's not that recent and I'd love to get this back. From what I understand I will have to change GUID types and attribute value but on what partitions?

I suppose the partition of 492 mb might be the missing Mac recovery partition but is surprisingly formatted in NTFS...

I attach below the details of macOS 353gb partition. There is an info - there's no volume associated with this partition - seems to be a problem. macOS partition details

  • Is it possible macOS was installed in a APFS partition? – David Anderson Oct 22 '18 at 21:23
  • This is a Macbook Pro mid 2015 and since APFS was introduced in 2017 I doubt it is. I think it's HFS/HFS+. Shall I execute some commands to check some more information or provide any other info to facilitate solving the problem? – user2923339 Oct 23 '18 at 4:39
  • I updated my post with details of macOS partition at the very bottom. – user2923339 Oct 23 '18 at 4:59
  • What version of macOS were you using? Is the the drive a HDD or SSD? Where you using encryption? Can you read the macOS volume from Windows? – David Anderson Oct 23 '18 at 5:38
  • 1
    I believe, when installing or upgrading to High Sierra, the result is the use or conversion to APFS format when a SSD is involved. With APFS, the recovery volume is include in the APFS container inside the APFS partition. While it is possible to confirm Partition 2 is formatted APFS, you might want to use gdisk to change the type to APFS and see if the computer boots macOS. Otherwise, I can post a procedure to confirm whether Partition 2 is JHFS+ or APFS. – David Anderson Oct 23 '18 at 16:07
2

In this case, the APFS partition type had been changed by EaseUS utility. That is why only Windows showed up on startup. I used gdisk to repair this and everything is on place, with no harm to the data.

How I repaired this?

I booted to Windows on bootcamp, downloaded gdisk for windows, opened cmd(terminal) as the administrator, opened the directory of downloaded gdisk and then the following list of commands inside of this program (each confirmed with enter key):

  1. gdisk64 \\.\PhysicalDrive0 ->this opens the gdisk program
  2. t
  3. 2 -> that is the number of your MacOS partition, in my case it is 2
  4. af0a -> hex code for the GUID APFS format
  5. w -> write
  6. y -> confirm

I hope I was able to help someone else by posting this answer.

  • 1
    Be sure to return later and mark the answer as correct. – David Anderson Oct 24 '18 at 13:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .