I'm running El Capitan 10.11.6 (15G21013) in Brazil.

Earlier today my machine switched to DST, which would be fine if the official date for the switch had not recently moved to Nov 4. Here is what I get on this Mac:

$ zdump -v /etc/localtime | grep 2018
/etc/localtime  Sun Oct 21 02:59:59 2018 UTC = Sat Oct 20 23:59:59 2018 BRT isdst=0
/etc/localtime  Sun Oct 21 03:00:00 2018 UTC = Sun Oct 21 01:00:00 2018 BRST isdst=1

A Linux machine I've checked did not switch to DST. There I get

$ zdump -v /etc/localtime | grep 2018
/etc/localtime  Sun Nov  4 02:59:59 2018 UTC = Sat Nov  3 23:59:59 2018 -03 isdst=0 gmtoff=-10800
/etc/localtime  Sun Nov  4 03:00:00 2018 UTC = Sun Nov  4 01:00:00 2018 -02 isdst=1 gmtoff=-7200

I understand that this is probably due to El Capitan not having been updated after the new DST date was decided.

I tried copying /etc/localtime from the Linux machine to the Mac (in Recovery mode). The date command in the terminal did display the correct time, but the clock on the menu bar did not. So I reverted the change, restoring the original file.

I've found up-to-date zoneinfo files at https://www.iana.org/time-zones but SIP does not allow me to update /usr/share/zoneinfo/ with zic.

How can I fix this?

  • Copy the whole /usr/share/zoneinfo/ from a newer Mac to my Mac? Will that work?

  • Change the time manually and wait until Nov 4 and then switch back to setting it automatically from Apple servers?

  • Change the timezone to one zone further west until Nov 4, leaving the time as is?

  • I ended up changing the timezone and leaving the time untouched. It's now Nov 4 and I've changed the timezone back to the correct one and all is well. Let's see next year...
    – lhf
    Commented Nov 4, 2018 at 10:16

1 Answer 1


This temporary fix worked fine for me and is the easiest to apply:

Change the timezone to one zone further west until Nov 4, leaving the time as is.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .