3

I've got an iPad Mini 4 running iOS 12 in a in-wall dock that I want to leave locked to one app and always on. The wall dock provides power to the iPad.

To have the iPad locked to one app I put it into Kiosk Mode.

I have set the settings for auto-lock as per the screenshot below, but I can't seem to get it to stay constantly on i.e. not to go into sleep mode.

I've had this working fine on other iPads using the same spec wall docks in the past, but I can't get it to work the latest time I've tried to deploy this. I think its got something to do with iOS 12 as my previous installs have been running iOS 10 and 11, and because they are locked into Kiosk app mode the OS never gets updated. I have also tested on my personal iPad mini 4 (iOS12) by plugging it into the power, setting sleep settings as per the screenshot above, and putting the iPad in kiosk mode locked to one app, but after about 30 mins it locks / dims the screen, it does seem to "wake" again if I get an alert on that device, but it only lasts for another 30 or so minutes.

Any ideas how I can get this to work so that the iPad will be locked to one app and the screen will stay on constantly?

Ideally I don't want to do this, but if necessary I would be willing to lock the device down in some sort of enterprise management mode where I can have more control over the device instead of using the Kiosk mode "hack" approach above if it resolved the issue.

(People may say that iPads are not designed to be always on/always charged, but I've had a few installs like this running for 2+ years with no issues).

screenshot of sleep settings on iOS 12

  • Did you set the Auto-Lock to Never in Settings app? – Nimesh Neema Oct 22 '18 at 6:12
  • @NimeshNeema which sub menu is auto lock > never located under ? – sam Oct 22 '18 at 15:08
  • Settings app -> Display & Brightness – Nimesh Neema Oct 22 '18 at 15:34
  • Try “Guided Access.” – HappyFace Nov 29 '18 at 15:33
  • @HappyFace guided access seems to be causing the issue, if i leave the iPad on without guided access it stays on indefinitely, but with guided access on, it turns off after c. 30 mins on iOS 12. – sam Nov 30 '18 at 15:13
1

I had the same problem with iPad and Guided Access, and the bug has been corrected with iOS 12.1.1 December 5 2018.

In the guided access config menu they added a switch "Mirror Display Auto-Lock" you have to switch on. It then says that the Guided Access will respect what you configured in the "Display & Brightness" menu.

I tested on my iPads, it works 🙂

More info on this website : https://flowkiosk.com/guided-access-fixed-with-new-setting/

  • Thanks, ive just setup a trail of this, ill let you know how i get on – sam Feb 1 at 11:31
  • 1
    I’ve tested this over the weekend and can confirm it works , thanks ! – sam Feb 3 at 16:23
2

You can set the iPad display to never turn-off automatically. Go to Settings app → Display & Brightness → Auto-Lock and select Never.


  • Its really strange i checked all of the settings they where exactly as per your screenshot, but still the device would sleep, i went back to it about 3 weeks later and it had started to stay on all the time, with not changes made to it. Not sure what happened but its working now – sam Nov 10 '18 at 20:16
  • It looks like my above comment was a case of "easy come, easy go" the issue has now re occurred, i have updated the question. – sam Nov 25 '18 at 22:22
  • Ive been doing some further work on this and it seems that when it was working i hadnt put the iPad into "single app mode" via guided access. See my answer below. – sam Nov 29 '18 at 14:48
2

Ive been doing some testing on the issue and reading up on the further reading below.

It seems that the issue is related to iOS12.

Ive done some testing and it seems that if you lock the iOS device (in this case an iPad mini 4) into "single app mode" using the guided access workflow and set sleep > never via settings, the screen lock doesn't work.

But if you put the iOS device into sleep > never and dont put the device into "single app mode" but rather just leave one app running, the iPad dosnt go to sleep. Its not an ideal solution as someone can still switch apps, but its an Ok work around. You should also disable notifications so they dont show up to the screen.

If i have time i may try adopting this iPad into MDM mode via Apple device manager, which i understand has another way to lock a device into "single app mode"

Further reading :

reddit.com

discussions.apple.com

discussions.apple.com

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .