2

Apple Watch won't unlock MacBook Pro

Up until yesterday, my MacBook Pro worked just fine with my Apple Watch - I walk up, touch the keyboard or trackpad, Mac unlocks and I get to work. No worries! Yesterday something changed and now my watch won’t unlock my laptop.

I’ve tried everything in the Apple Support post, including repairing my phone/watch, re-establishing two-factor authentication (2FA), and rebooting my laptop, iPhone, and watch. All to no avail. I tried the @Morwen suggestion with Messages because there was a gap in my message history, but that didn't do it.

When I try to enable my watch, I get the error message shown below (albeit after about 6 or 7 minutes later, not quickly like the gif image). My watch, iPhone, and MacBook are all signed in and communicating with Apple.

enter image description here

The only thing I can think of that might play into this is that I was setting up a personal VPN on my home router last night, but I’ve turned that off as part of my troubleshooting (and couldn’t replicate the issue).


Digging a little further, I found this message (repeatedly since yesterday) in my Console logs. It looks like I have two permissions conflicting, but I can't tell which is which, nor where to go to change one of them...

Oct 21 02:17:54 Johns-MBP com.apple.preference.security.remoteservice[790]: objc[790]: Class AWDSecurityPrefAutoUnlockSetup is implemented in both /System/Library/PreferencePanes/Security.prefPane/Contents/XPCServices/com.apple.preference.security.remoteservice.xpc/Contents/MacOS/com.apple.preference.security.remoteservice (0x10d6018e0) and /System/Library/PreferencePanes/Security.prefPane/Contents/MacOS/Security (0x10fd0b210). One of the two will be used. Which one is undefined.


Environment includes:

  1. 2017 15" MacBook Pro with Mojave (updated)
  2. Apple Watch Series 3 with Cellular (updated)
  • 1
    Do you have any issues with any bluetooth connections on the MBP? I had this same problem when I updated to Mojave. Turn off bluetooth on your mac, delete: /Library/Preferences/com.apple.Bluetooth.plist turn bluetooth back on. See if that helps. – fsb Oct 21 '18 at 13:45
  • @fsb - that totally fixed it! Thanks a bunch, fsb. Can you put it in as an answer so I can select it as the one that resolved my issue? – AFK Oct 21 '18 at 14:23
1

I had a similar issue when I updated to Mojave. These steps solved my problem:

  1. Turn off bluetooth on the Mac
  2. Open Finder and navigate to ~/Library/Preferences
  3. Delete the file com.apple.bluetooth.plist
  4. Turn bluetooth back on
  5. If Allow your Apple Watch to unlock your Mac is off, check the box to turn it on
  6. Test if your Watch unlocks the Mac
  • 1
    Thanks fsb - this totally solved the issue I was having. My MBP is happily unlocking with my Apple Watch again. FWIW, and anybody else that might run into a similar problem, the console log entries that I posted in the original query coincided precisely with my attempts to unlock my computer with my watch; they have stopped since I followed the instructions that fsb gave. – AFK Oct 21 '18 at 16:27
0

I don't know my solution still works with OP's system - however unlocking your iPhone solved the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .