I am trying to sign in to iCloud after having signed out. I keep getting the message that my account is already signed in to iCloud and that I should delete it from Internet Accounts and sign in again.

  • It's not listed in Internet Accounts.

  • I've signed out of iTunes

  • and any other app that has used this account (list these please with an edit)

  • I've rebooted.

    Nothing seems to help so I wonder how I can troubleshoot this further.

  • are you actually signed in or is it a fake, can you do anything in iCloud
    – Ruskes
    Oct 20, 2018 at 21:11

2 Answers 2


I had the exact same issue It only occurred on one Mac, all the others were fine.

I even removed the device from my appleid.apple.com page as well, then it asks me to authorise the device first, before giving the exact same error.

In my case I have removed it from iTunes, FaceTime, Messages, and Game Centre. Im not using photos or books on here.

It started after changing my appleid password.

The fix for me was the following command in terminal: defaults delete MobileMeAccounts

After this I was able to login again and add all my stuff back. I have done some other steps, but as they did not help, I won't list them, unless people do have issues after this fix. (like deleting my keychain and some terminal stuff that seems highly unlikely to help)

  • 1
    I had the same problem and I did nothing except the defaults delete MobileMeAccounts command, which fixed it. So everything else is probably not necessary.
    – heilerich
    Nov 14, 2019 at 8:32
  • Can confirm. I can also confirm that my Apple ID ends in @me.com, which might be a) why the account is affected and b) why it is not caught by Apple.
    – Henrik
    Jan 26, 2020 at 15:42
  • The deletion seems to have helped me as well - it is likely not related to the email domain.
    – Richlv
    Jan 27, 2020 at 16:55
  • This solved the problem for me as well, and an additional problem as well: I was getting "an unknown error occurred" when signing to Messages and FaceTime on a new MacBook; turns out I had migrated an account from my old Mac that had corrupt Internet Accounts. Fixing the problem with defaults delete MobileMeAccounts on the old Mac, then erasing the new Mac and re-migrating the fixed account solved the problem. May 2 at 4:13

I had a similar issue and managed to get it cleared up by using Onyx.app to clear all the system caches - https://www.titanium-software.fr/en/onyx.html

Possibly restarting in "Safe Boot" mode by holding the shift key when restarting would have done the same.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .