1

SPECS:

  • Computer: MacBook Pro (Retina, 15-inch, Mid 2014) MacBookPro11,3.
  • Memory: 16 GB 1600 MHz DDR3
  • HD: 1 TB APPLE SSD SM1024F Apple_APFS
  • GRAPHICS: NVIDIA GeForce GT 750M 2048 MB Intel Iris Pro 1536 MB

Everytime I restart my computer or power it on my computer won't boot. I have to enter recovery mode and reinstall Mojave. I've run disk utility but no problems are detected.

Sceenshot of verbose mode: enter image description here

0

I had the same issue and this fixed it for me. https://www.justinsilver.com/technology/os-x-el-capitan-10-11-1-hanging-on-boot-fixed/

  • Your answer got my started on a solution. Kexts appeared to be the problem. – KahunaCoder Dec 2 '18 at 18:51
0

Ok here is how I fixed my problem. As noted in a comment the issue looks to be caused by a system extension. Here's what I did to fix it.

  1. I ran this command in my terminal: system_profiler SPExtensionsDataType > ~/Desktop/kextList.txt
  2. I opened ~/Desktop/kextList.txt in a text editor and looked for Obtained from: Not Signed
  3. I removed all extensions (kexts) that wasn't signed from /library/extensions and /system/library/extensions and placed them in ~/Documents/Disabled Extensions/
  4. I then rebooted my computer but I still had the same problem.
  5. I rebooted again in verbose mode by holding Command V on reboot
  6. I noticed that this extension was loading com.iospirit.driver.rbiokithelper
  7. I then went through ~/Desktop/kextList.txt and looked for Obtained from: Identified Developer that also had Loaded: Yes set.
  8. I found com.iospirit.driver.rbiokithelper was loaded. I googled it and found it was for Remote Buddy which I no longer used.
  9. I moved /Library/Extensions/RBIOKitHelper.kext to ~/Documents/Disabled Extensions/ and rebooted.
  10. Problem solved! 8-)

I hope this helps anyone else that has a similar problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .