1

For most contacts, if iMessage is not available (no internet, iMessage disabled in settings, etc), I am able to send a SMS txt message instead.

But I have a couple contacts that will not attempt an SMS message. The gray placeholder text in the text input box is "iMessage" instead of "Text Message" and when attempting to send the message, the arrow button is blue and not green. When pressing the button it says you need to enable iMessage.

The contacts are configured with an actual mobile phone number and sms messaging works for other contacts configured in the same way.

The contacts have sms enabled on their phones and they are not blocking me or anything like that. I have even verified the settings on one of their phones as part of trying to figure this out.

When iMessage is enabled, sending iMessages to them works fine.

Things I have tried:

  • Reset network settings
  • Delete entire message history and a contact having the problem
  • Disable iMessage, including disabling iMessage on both my phone and one of the contacts' phones at the same time to test if that was an issue
  • Turn off both wifi and mobile data
  • Log out of my apple id for the messages app
  • Reboot phone at various points in trying things, including forced restart (vol up, vol down, hold power until restarts)
  • Restart messages app at various points in trying things

Any ideas?

  • do you have they correct phone number in your contacts – Ruskes Oct 20 '18 at 0:43
  • yes, double checked that and even re-entered it and also tried with the country code and without – Joshua Coady Oct 22 '18 at 21:52
  • did you try to take them off the iMessage list – Ruskes Oct 22 '18 at 22:09
  • how do you do that? – Joshua Coady Oct 23 '18 at 2:57
  • 2
    they may have SMS turned off on their side – cmason Oct 23 '18 at 18:40

You must log in to answer this question.

Browse other questions tagged .