2

I am trying to restore media from an external drive to another external drive now both the partitions have been formatted with the same partition map GUID partition map (I am also getting an APFS partition message on clicking the partition map option available under disk utility)). Now whenever I am trying to restore the partitions, I am coming across several errors.

This was the first attempt: I selected the main volume (as the source volume from which the media files are to be restored) which is at the top of the volume tree (Sandisk Ultramedia)

I am facing this error! (I have attached some screenshots to further explain my problem)

Error No.1

enter image description hereenter image description here enter image description here

Error No.2

This time I selected the volume within the container APFS volume (as the source disk from where the media files are to be restored) which is the Sandisk USB External Drive/MacOS USB. But, again I got the same error.

enter image description here enter image description here

  • Please post just the error message and not your whole desktop - it makes it very difficult to read. – Allan Oct 19 '18 at 22:33
  • @Allan sorry I forgot to crop the pics in hurry, I'll do it right away. – Sayan Oct 20 '18 at 4:48
  • A tip for screenshotting so you don't have to crop the images each time and it'll look better: If you press ⌘ + Shift + 4 instead of 3, a different kind of cursor will pop up, and if you hit space you can take screenshots of individual windows. – abc Oct 20 '18 at 22:15
1

This seems to be a bug with macOS Mojave. Even I tried to do the same. I came across the same errors you are facing. Luckily, I was able to clone the disks which is same as restoring.

There are several ways to clone a disk. You can use some utility tools available on and off the macOS App Store.

I tried this https://www.shirt-pocket.com/SuperDuper/SuperDuperDescription.html cloning utility to clone my main drive to an external SSD both having the same partition map - APFS. This should solve the problem.

  • 1
    I downloaded the app and it did work. Now my problem is solved. – Sayan Nov 14 '18 at 8:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .