I have English and emoji keyboards enabled.

In iMessage, I can just type "serbia" and I get the emoji for the Serbian flag. However, in Signal, when I type Serbia, I just get Serbia and Serbian as suggestions. I have another friend using the Signal app on iOS who does get emoji recommendations from his keyboard, so I have seen that it is possible, but all my recommended auto-replacements are textual. I don't understand why this is different on my iPhone X and his iPhone 7.

It's very annoying to have to scroll through all the emojis and pick one rather than just type a word and get it.

What is happening and how do I fix it?

  • I am using an Apple device. This feature works in some Apple devices and not others. Is my keyboard misconfigured? What aspects of iOS are failing here and how do I configure them correctly (as my friend's is correctly configured)? Commented Oct 18, 2018 at 21:04
  • Cool, love the inviting community being a new contributor on a stack forum. Very helpful downvotes. Commented Oct 18, 2018 at 21:15
  • Does the Serbian flag pop up when you type serbia in other apps where autocomplete is active (like Mail)?
    – IconDaemon
    Commented Oct 18, 2018 at 23:34
  • Yeah, in other apps, just not signal. Commented Oct 19, 2018 at 6:14

2 Answers 2


Bafflingly, this was the answer:


Apparently, the algorithm for recommendation for emoji replacement is per-app, which makes sense in that you speak differently in email than you do on twitter, but apparently, if you've never spun a random string of emojis together in a new app, the keyboard has to learn it from 0.

So to fix this problem is: open your regular keyboard in the app of interest and type some words, then open your emoji keyboard and type a ton of random emojis (not even necessarily the one you want!). After you do, the recommendations will recognize that you mix English and Emoji and recommend them together, even from your English keyboard. They will appear on the right hand side recommendation just where they do in iMessage.

(The link used Angola, not Serbia.)


Try using the Text Replacment feature.

Settings > General > Keyboard > Text Replacement.

Phrase = 🇷🇸 & Shortcut = #serbia

example screenshot

  • 1
    Note: using a hashtag helps if you do not want to auto-replace the shortcut phrase/word. Commented Oct 19, 2018 at 1:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .