I have the following earbuds model: Panasonic Wireless Bluetooth in-Ear Headphones with Sound Mic Controller & Quick Charge Function Blue (RP-HJE120B-A)

Here's my macbook Model Identifier: MacBookPro11,4 System Version: macOS 10.14 (18A391)

I am trying to pair my earbuds following the directions in the manual, but to no avail. I've paired them with my phone, but I know that that isn't interfering (I turned bluetooth off on my phone. I also tried to delete the file at /Library/Preferences/com.apple.Bluetooth.plist also no go. Any suggestions? Other devices like computers pop up and my UE MINI BOOM speaker is showing up in the menu (though it's already been paired).

  • hold Shit+Option and click on BT icon, open the Debug and do the Reset
    – Ruskes
    Commented Oct 19, 2018 at 1:56

3 Answers 3


I tried a PRAM Reset and it seemed to work for me. Other things you can try are

  • Check your system log tail -f /private/var/log/system.log If you see something like the following in your log, then likely the PRAM reset will help

com.apple.xpc.launchd[1] (com.apple.preference.sound.remoteservice[4642]): Service exited due to SIGKILL | sent by com.apple.preference.sound.remot[4642]

  • Also try the following
    • sudo mv /Library/Audio/Plug-Ins/HAL/BluetoothAudioPlugin.driver ~/Desktop
    • Restart
    • sudo cp -R ~/Desktop/BluetoothAudioPlugin.driver /Library/Audio/Plug-Ins/HAL/

Solved: I misread the manual, but I do feel it was misworded

Here's what the manual says:

Pairing (Registration) this unit with the Bluetooth ® device for connection

1 Press and hold the power button
of this unit until the LED blinks

When pairing a device for the first time : approx. 3 seconds

When pairing a second or subsequent devices : approx. 5 seconds

I thought it said when pairing for the second time, but it meant second device. So just hold down longer.


I had several error logs similar to the following system Logs:

Dec 22 23:09:01 iMac com.apple.xpc.launchd[1] (com.apple.WebKit.Networking): Service exited with abnormal code: 1

Dec 22 23:23:18 iMac com.apple.xpc.launchd[1] (com.apple.duetknowledged[813]): Service exited with abnormal code: 78

I simply did the "hold Shift+Option and clicked on the BT icon", as explained previously by Buscar and I opened the Debug option in the menu. However, in my Mojave system I had to do a reset and a remove a couple of times but eventually, they all connected. It's all working well now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .