2

I've picked up a used 2010 Macbook Air. The previous owner seems to have wiped OS X leaving me with only the 'OS X Utilities' application available. I can't use the install option as I receive the 'This item is not available' after signing into the App Store.

I've tried creating a bootable USB of 10.6 (original OS) and 10.11 (last installed OS) but either get a Kernel Panic or a stop sign respectively. I've also tried the 'Internet Recovery' option, but can't seem to access it on boot - I've heard it may not be installed.

I don't have access to another Mac - only PC.

I'm using TransMac for Windows to create the bootable USB. It initially appears successful at setting up the drive but when booting the errors appear.

How can I set this machine up?

Your help is much appreciated

  • Pretty sure internet recovery is built into the firmware and can't be removed. If Bootable USB's are failing, it sounds like there's a hardware problem. – Wowfunhappy Oct 18 '18 at 20:11
  • The previous owner provided a photo of the laptop working - so I don't think it's a hardware issue. I also don't think that Internet Recovery is available for all devices, so I'm assuming mine doesn't have it. I'm not 100% sure if I'm creating the bootable USB correctly - I've 'burned' a dmg of the retail version of OS X. Is there a separate recovery version? – Callum Oct 18 '18 at 20:13
  • how are you creating bootable USB without Mac ? – Ruskes Oct 18 '18 at 20:20
  • I'm using TransMac for Windows. It initially appears successful at setting up the drive but when booting the errors appear. – Callum Oct 18 '18 at 20:23
  • topbestalternatives.com/transmac Alternatives – Ruskes Oct 18 '18 at 20:26
1

You can force Internet Recovery mode using the download version instead of the stored version and reset the Mac that way: https://support.apple.com/en-us/HT201314

Specifically, this method:

To manually start up from macOS Recovery over the Internet, press and hold Option-Command-R or Shift-Option-Command-R at startup

  • Thanks for your response. I tried this, but as I mentioned in the OP - I don't think the firmware has been updated to include this. – Callum Oct 19 '18 at 5:00
  • Ah, I did wonder if the Recovery method you used was the normal recovery mode or the 'force-internet' mode. If it doesn't work on your Late 2010 MBA your options are limited indeed. One thing you can do from the recovery environment, even if you cannot install macOS, is use the environment to create a Recovery Disk from the laptop itself. Using the Terminal utility you can download a macOS installer and create a new USB drive. It should also be possible to upgrade the firmware from that environment. For example, the EFI update can be found here: support.apple.com/kb/DL1494?locale=en_US – John Keates Oct 19 '18 at 17:13
  • Thanks for this suggestion - I tried initially burning the firmware update to a USB and trying to boot into that, but I couldn't see any option to select the drive. Can you advise as to how I can use terminal (within the recovery) to 'download a macOS installer and create a new USB drive'? Thanks – Callum Oct 20 '18 at 20:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .