0

If I go to About This Mac and click on the Storage tab, it tells me that I have 500 GB of Flash Storage and that 15.49 GB of 399.57 GB is free.

It will also tell me that 226 GB is for System, 130 GB is for Documents, and 25.8 GB is for Apps.

If I do: sudo du -hx -d 0 /*

 19G    Applications
2.5M    bin
 15K    dev
4.0K    etc
1.0K    home
1.9G    Library
1.0K    net
1.0K    Network
 16G    private
1.1M    sbin
6.6G    System
4.0K    tmp
157G    Users
848M    usr
4.0K    var
 36K    Volumes

Tools like OmniDiskSweeper or Disk Inventory X will report the same basic information. They will generally account for the space that the Storage tab says is being used by Documents and Applications, but I cannot seem to figure out where the 226 GB of files are that the "System" part is using. I had this situation come up once before and rebooting the machine cleared out the used space and I got a couple hundred GB back. I could do that again, but I would like to be able to track down what these files are.

Any suggestions?

  • is that your whole output of the command? because I am getting operation not permitted at certain places. – scipsycho Oct 18 '18 at 13:38
  • No. I have checked those places, but cannot find anything. – ericg Oct 18 '18 at 13:39
  • I am also seeing some difference like 20 gigs but yours is way to high! Do you have any other OS installed (just to be sure)? – scipsycho Oct 18 '18 at 13:42
  • no. just macOS. The space is obviously being used by temporary files which will go away if I reboot...I just cannot seem to locate them. it's weird. – ericg Oct 18 '18 at 13:47
  • try the answer below, I have faced a similar issue. – scipsycho Oct 18 '18 at 13:49
1

My problem is related to the question What is the correct way to eject a APFS dmg from the command line?

What was going on is I was mounting APFS DMGs via hdiutil attach and only ejecting one of the disks. The disk left behind was taking up hard drive space. After I fully ejected the volume, my hard drive space came back.

The way I was able to spot this easily was by using Apple's Disk Utility application and saw a bunch of grayed out Disk Images.

  • oh! very peculiar. great you solved it! – scipsycho Oct 19 '18 at 18:57
0

Well, I remember I have faced this problem before. This had to do with Spotlight indexing. Try this and tell me if there's a difference.

Go to System Preferences > Spotlight > Privacy

Click the plus sign and add your whole hard drive! enter image description here

enter image description here

Then simply remove it and spotlight will start indexing your whole system. It will take some time and then see your usage. See if it changes!

  • A good idea, but does not seem to be helping. I did also try the command line equivalent of "sudo mdutil -E /" with no effect. – ericg Oct 18 '18 at 14:07
  • I think it will take some time as you have lot of things to be indexed! I am saying this because this happened with me and I resorted to calling Apple directly and ended up suggesting this myself which "worked". – scipsycho Oct 18 '18 at 14:18
  • found the answer about who was taking all of the space...see my posted answer. – ericg Oct 19 '18 at 18:26
-1

I had a similar problem and it was turned out the the Library folder had almost 125 GB. there are 2 Library folders and I'm referring to the one in my home directory. Not the one you show thats on the same level as Applications and Users. In that Library folder there was a folder named Mobile Documents. That folder contained around 90 GB. I was using iCloud drive as a backup for my main drive and those files were also showing up in my /Library/Mobile Documents. I don't understand what was going on or how the files were stored but once I removed the files from the Icloud Drive, it freed up close to 90 gB on my disk drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .