My MacBook Pro 17" Late 2011 is suddenly unable to boot, keeps restarting over and over again, like 10-20 times until it decides to shut down. As it restarts each time, it displays a message like this one:

Your computer restarted because of a problem

I'm able to boot the computer into Single User mode, Safe Mode and Startup Manager. I could not boot into Recovery Mode.

I was eventually able to make my Mac boot normally going into Safe Mode and running first aid on my boot volume in Disk Utility and then doing the same thing booting off a USB Recovery Partition.

Upon booting normally and logging in, I received these two pop-ups: Panic Medic Boot

System Extension Blocked

after opening Security & Privacy System Preferences I see this:

System Preferences

After I clicked "Allow", another pop-up appeared (I forgot to capture it) prompting me to restart the computer to allow the extension, which I refused for fear of not being able to boot again.

Below is kernel panic report I also received after logging in:

Anonymous UUID: AE0383DF-F1C1-F15D-9A48-98BBF3377CD6

Mon Jan 1 01:18:51 2001

*** Panic Report ***

panic(cpu 4 caller 0xffffff802678776f): Kernel trap at 0xffffff8026c123f0, type 14=page fault, registers:

CR0: 0x000000008001003b, CR2: 0xffffff7fa94c5a60, CR3: 0x000000002aeb3000, CR4: 0x00000000000626e0

RAX: 0x0000000000000001, RBX: 0x0000000000000000, RCX: 0x0000000001500000, RDX: 0xffffff804611c9d0

RSP: 0xffffff9213ed3c60, RBP: 0xffffff9213ed3cc0, RSI: 0x0000000000000016, RDI: 0xffffff804611c9d0

R8: 0x0000000000000001, R9: 0x0000000000000020, R10: 0x00000000000003fe, R11: 0x0000000000000000

R12: 0xffffff802705dd60, R13: 0xffffff7fa94c5a50, R14: 0xffffff8046f36520, R15: 0xffffff8046ffc820

RFL: 0x0000000000010286, RIP: 0xffffff8026c123f0, CS: 0x0000000000000008, SS: 0x0000000000000010

Fault CR2: 0xffffff7fa94c5a60, Error code: 0x0000000000000000, Fault CPU: 0x4, PL: 0, VF: 1

Backtrace (CPU 4), Frame : Return Address

0xffffff9213ed3730 : 0xffffff802666c1c6

0xffffff9213ed3780 : 0xffffff8026795274

0xffffff9213ed37c0 : 0xffffff8026787544

0xffffff9213ed3830 : 0xffffff802661e1e0

0xffffff9213ed3850 : 0xffffff802666bc3c

0xffffff9213ed3980 : 0xffffff802666b9fc

0xffffff9213ed39e0 : 0xffffff802678776f

0xffffff9213ed3b50 : 0xffffff802661e1e0

0xffffff9213ed3b70 : 0xffffff8026c123f0

0xffffff9213ed3cc0 : 0xffffff8026c31b8d

0xffffff9213ed3d40 : 0xffffff8026c1fe7d

0xffffff9213ed3da0 : 0xffffff8026c1d2e3

0xffffff9213ed3e10 : 0xffffff8026c2a384

0xffffff9213ed3e60 : 0xffffff8026c91376

0xffffff9213ed3e80 : 0xffffff8026c7287a

0xffffff9213ed3f00 : 0xffffff8026c72467

0xffffff9213ed3f50 : 0xffffff8026c740c6

0xffffff9213ed3fa0 : 0xffffff802661d557

BSD process name corresponding to current thread: kernel_task

Boot args: -no_compat_check -v

Mac OS version:


Kernel version:

Darwin Kernel Version 17.7.0: Thu Jun 21 22:53:14 PDT 2018; root:xnu-4570.71.2~1/RELEASE_X86_64

Kernel UUID: 1AE5ACFD-3B6F-3D74-AD52-31F1430DBC6F

Kernel slide: 0x0000000026400000

Kernel text base: 0xffffff8026600000

__HIB text base: 0xffffff8026500000

System model name: MacBookPro8,3 (Mac-942459F5819B171B)

System uptime in nanoseconds: 8976214811

last loaded kext at 8615648405: com.apple.kext.AMD6000Controller 1.6.8 (addr 0xffffff7fa9aa6000, size 2097152)

loaded kexts:

com.apple.kext.AMD6000Controller 1.6.8

com.apple.driver.AppleLPC 3.1

com.apple.driver.SMCMotionSensor 3.0.4d1

com.apple.Dont_Steal_Mac_OS_X 7.0.0

com.apple.driver.AppleSMCPDRC 1.0.0

com.apple.driver.AppleFIVRDriver 4.1.0

com.apple.driver.AppleSMCLMU 211

com.apple.driver.AppleMuxControl 3.20.13

com.apple.driver.AppleMCCSControl 1.5.5

com.apple.driver.AppleOSXWatchdog 1

com.apple.driver.AppleIntelSNBGraphicsFB 10.0.4

com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0

com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0

com.apple.driver.AppleThunderboltIP 3.1.1

com.apple.iokit.IOBluetoothUSBDFU 6.0.7f10

com.apple.driver.AppleUSBTCKeyEventDriver 254

com.apple.driver.AppleUSBTCKeyboard 254

com.apple.driver.AppleUSBTCButtons 254

com.apple.driver.AppleIRController 353

com.apple.driver.CoreStorageFsck 546.50.1

com.apple.driver.AppleFileSystemDriver 3.0.1

com.apple.filesystems.hfs.kext 407.50.6

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

com.apple.BootCache 40

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0

com.apple.AppleSystemPolicy 1.0

com.apple.filesystems.apfs 748.51.0

com.apple.driver.AirPort.Brcm4331 800.21.30

com.apple.driver.AirPort.Brcm4360 1240.19.1a3

com.apple.driver.AppleFWOHCI 5.5.9

com.apple.iokit.AppleBCM5701Ethernet 10.3.1

com.apple.driver.AppleAHCIPort 329.50.2

com.apple.driver.AppleSmartBatteryManager 161.0.0

com.apple.driver.AppleACPIButtons 6.1

com.apple.driver.AppleHPET 1.8

com.apple.driver.AppleRTC 2.0

com.apple.driver.AppleSMBIOS 2.1

com.apple.driver.AppleACPIEC 6.1

com.apple.driver.AppleAPIC 1.7

com.apple.driver.AppleIntelCPUPowerManagementClient 220.50.1

com.apple.nke.applicationfirewall 183

com.apple.security.TMSafetyNet 8

com.apple.security.quarantine 3

com.apple.driver.AppleIntelCPUPowerManagement 220.50.1

com.apple.iokit.IONDRVSupport 519.20

com.apple.driver.AppleHDAController 281.52

com.apple.iokit.IOHDAFamily 281.52

com.apple.iokit.IOAudioFamily 206.5

com.apple.vecLib.kext 1.2.0

com.apple.driver.AppleSMBusPCI 1.0.14d1

com.apple.kext.AMDLegacySupport 1.6.8

com.apple.driver.AppleGraphicsControl 3.20.13

com.apple.driver.AppleSMBusController 1.0.18d1

com.apple.iokit.IOFireWireIP 2.2.9

com.apple.driver.IOPlatformPluginLegacy 1.0.0

com.apple.driver.IOPlatformPluginFamily 6.0.0d8

com.apple.AppleGPUWrangler 3.20.13

com.apple.AppleGraphicsDeviceControl 3.20.13

com.apple.iokit.IOGraphicsFamily 519.20

com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0

com.apple.driver.AppleThunderboltEDMSink 4.1.4

com.apple.driver.AppleThunderboltDPOutAdapter 5.5.5

com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 6.0.7f10

com.apple.iokit.IOBluetoothHostControllerUSBTransport 6.0.7f10

com.apple.iokit.IOBluetoothHostControllerTransport 6.0.7f10

com.apple.iokit.IOBluetoothFamily 6.0.7f10

com.apple.driver.AppleUSBMultitouch 262

com.apple.driver.usb.IOUSBHostHIDDevice 1.2

com.apple.driver.CoreStorage 546.50.1

com.apple.driver.usb.cdc 5.0.0

com.apple.driver.usb.networking 5.0.0

com.apple.driver.usb.AppleUSBHostCompositeDevice 1.2

com.apple.driver.usb.AppleUSBHub 1.2

com.apple.filesystems.hfs.encodings.kext 1

com.apple.driver.AppleThunderboltDPInAdapter 5.5.5

com.apple.driver.AppleThunderboltDPAdapterFamily 5.5.5

com.apple.driver.AppleThunderboltPCIDownAdapter 2.1.3

com.apple.driver.AppleXsanScheme 3

com.apple.iokit.IOAHCIBlockStorage 301.40.2

com.apple.driver.AppleThunderboltNHI 4.7.2

com.apple.iokit.IOThunderboltFamily 6.7.8

com.apple.iokit.IO80211Family 1200.12.2

com.apple.driver.corecapture 1.0.4

com.apple.iokit.IOFireWireFamily 4.7.2

com.apple.iokit.IOEthernetAVBController 1.1.0

com.apple.driver.mDNSOffloadUserClient 1.0.1b8

com.apple.driver.AppleUSBMergeNub 900.4.1

com.apple.iokit.IOAHCIFamily 288

com.apple.driver.usb.AppleUSBEHCIPCI 1.2

com.apple.driver.usb.AppleUSBUHCIPCI 1.2

com.apple.driver.usb.AppleUSBUHCI 1.2

com.apple.driver.usb.AppleUSBEHCI 1.2

com.apple.driver.usb.AppleUSBHostPacketFilter 1.0

com.apple.iokit.IOUSBFamily 900.4.1

com.apple.driver.AppleUSBHostMergeProperties 1.2

com.apple.driver.AppleEFINVRAM 2.1

com.apple.driver.AppleEFIRuntime 2.1

com.apple.iokit.IOSMBusFamily 1.1

com.apple.iokit.IOHIDFamily 2.0.0

com.apple.security.sandbox 300.0

com.apple.kext.AppleMatch 1.0.0d1

com.apple.driver.DiskImages 480.60.1

com.apple.driver.AppleFDEKeyStore 28.30

com.apple.driver.AppleEffaceableStorage 1.0

com.apple.driver.AppleKeyStore 2

com.apple.driver.AppleUSBTDM 439.70.3

com.apple.driver.AppleMobileFileIntegrity 1.0.5

com.apple.iokit.IOUSBMassStorageDriver 140.70.2

com.apple.iokit.IOSCSIBlockCommandsDevice 404.30.2

com.apple.iokit.IOSCSIArchitectureModelFamily 404.30.2

com.apple.iokit.IOStorageFamily 2.1

com.apple.driver.AppleCredentialManager 1.0

com.apple.driver.KernelRelayHost 1

com.apple.iokit.IOUSBHostFamily 1.2

com.apple.driver.usb.AppleUSBCommon 1.0

com.apple.driver.AppleBusPowerController 1.0

com.apple.driver.AppleSEPManager 1.0.1

com.apple.driver.IOSlaveProcessor 1

com.apple.iokit.IOReportFamily 31

com.apple.iokit.IOTimeSyncFamily 680.15

com.apple.iokit.IONetworkingFamily 3.4

com.apple.driver.AppleACPIPlatform 6.1

com.apple.driver.AppleSMC 3.1.9

com.apple.iokit.IOPCIFamily 2.9

com.apple.iokit.IOACPIFamily 1.4

com.apple.kec.pthread 1

com.apple.kec.Libm 1

com.apple.kec.corecrypto 1.0


Model: MacBookPro8,3, BootROM MBP81.0050.B00, 4 processors, Intel Core i7, 2.4 GHz, 16 GB, SMC 1.70f5

Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In

Graphics: AMD Radeon HD 6770M, AMD Radeon HD 6770M, PCIe

Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x859B, 0x435438473353313333394D2E4D3136464E00

Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x859B, 0x435438473353313333394D2E4D3136464E00

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (

Bluetooth: Version 6.0.7f10, 3 services, 18 devices, 0 incoming serial ports

Network Service: Wi-Fi, AirPort, en1

Serial ATA Device: Samsung SSD 850 EVO 250GB, 250.06 GB

Serial ATA Device: TOSHIBA MK7559GSXF, 750.16 GB

USB Device: USB 2.0 Bus

USB Device: FaceTime HD Camera (Built-in)

USB Device: Hub

USB Device: BRCM2070 Hub

USB Device: Bluetooth USB Host Controller

USB Device: Apple Internal Keyboard / Trackpad

USB Device: USB 2.0 Bus

USB Device: Hub

USB Device: IR Receiver

Thunderbolt Bus: MacBook Pro, Apple Inc., 25.1

I tried to restart my computer again and the same thing as above happened.

Here is my EtreCheck report: https://pastebin.com/U5DWYDrb

Thanks for your help!

edit: updated EtreChcek report after doing what LangLangC suggested: https://pastebin.com/A6eu7m5g

  • Can you boot a full install of an OS from USB? Commented Oct 17, 2018 at 14:01
  • to LangLangC: I could if I had such a USB, what I booted into off the USB was not a full install of macOS. Why do you think I have iBoostUp and any USB Tethering stuff? I can't see any mention such things in my post.
    – yssup
    Commented Oct 17, 2018 at 15:24
  • Some of those things seem present in the dump you pastebinned. USBTethering is from "Joshua Wise" in the screenshot above. You could install a full OS onto a USB-stick. A really fresh install still crashing then would lead back to hardware issues (2011 and last loaded kext AMD might ring a bell; or several) Commented Oct 17, 2018 at 15:59
  • I won't repeat the suggestion about the keylogger. But the sorest thumb that sticks out now is: what is in /etc/hosts, who installed that? And obviously /Library/Application Support/.SystemEngine/observer (part of what? Why hidden?). Given that GateKeeper and SIP or off, Flash is on it might not hurt to give malwarebytes.com a run… EtreCheck said: "System modifications - There are a large number of system modifications running in the background." You might also want to check SystemInformation.app for non-Apple software/extensions. Commented Oct 18, 2018 at 15:20
  • So, unfortunately I had to reinstall my Mac OS High Sierra because I was no longer able to boot into the system. How should I go about restoring the majority of my files and setting from my Time Machine backup now? As I suppose I should not do the complete system restore from backup, should I?
    – yssup
    Commented Oct 19, 2018 at 9:53

1 Answer 1


All those boot modes you tried and reported seem to indicate one thing:

This machine has a hosed system installation. The problems inherent are now so numerous that a clean install will likely be the best and fastest approach to rectify the situation.

com.ab.klpro.plist should not be on any system, as bad as com.ab.klpro.plist "jump connect", com.ab.kl.observer.plist

/Library/LaunchDaemons/net.exirion.ssdfanctrl.plist and com.tunabellysoftware.TGFanHelper.plistare both fan controllers. They are in conflict by definition.

Your DiskWarrior version is outdated: 5.0 is installed, 5.2 available Viscosity is apparently version 1.2 when 1.7 is available

In /Library/Extensions you have the
- HoRNDIS.kext from an USB Tethering software that seems questionable - engine.kext is also present without need?

MacAppBlocker.app is from 2015 and likely outdated as well.

EcammAudioLoader: 1.0.4 (installed 2017-01-05) and
CallRecorder: v2.5.22 (installed 2017-01-05)

Are also indicative of cruft accumulated.

The file /Library/.A_o_b_o_p_r_o/AbkPro.app may be related to malware but is evidently in any case from PUPA software. The high network traffic is also a warning sign.

These are just those problems found by EtreCheck. MalwareBytes and similar programmes will likely yield even more now.

You have two options now:

  1. Remove all the cruft from the last years by hand. Perhaps possible, and I would try that to learn something. But that will at least cost you time, and may not be successful.

  2. Make a backup, (make a bootable backup), wipe the drive, make a clean install of High Sierra. Do not use Migration Assistant. Install the software you need one by one.

  • I removed everything related to ecamm, call recoder, horndis and both the fan controllers. MacAppBlocker.app has worked reliably ever since I installed several years ago, so as the Aobo KeyLogger, not gonna remove those.
    – yssup
    Commented Oct 17, 2018 at 15:52
  • @yssup Your choice. Does the problem persist after clearing out the cruft (including caches), disk repair and running more diagnostics? If it's still there you might want to update your question (incl a fresh kernel panic log). (and those apps you want to keep are at their latest versions? How about removing them temporarily and see if things improve?) Commented Oct 17, 2018 at 15:56
  • 1
    Unfortunately, the problem persists :-/ . I will update my questions with new logs. The apps I wanna keep are the latest versions.
    – yssup
    Commented Oct 18, 2018 at 12:26
  • I added new EtreCheck report
    – yssup
    Commented Oct 18, 2018 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .