I've got 2018 MacBook Pro 15" (Radeon Pro 560X), which I'm connecting to external LG 4K display (27UD69P-W) via Satechi Type-C to HDMI Adapter (says 4K/60hz on the box), but the display is running 30hz.

enter image description here

How do I make it do 60hz?

Thank you!

  • Weirdly enough, this person seems to have the exact same problem as you today: Unable to get 4K @ 60Hz resolution
    – user305880
    Commented Oct 17, 2018 at 18:17
  • @jackgmarch ouch, that guy has DisplayPort, and I thought I can solve this by switching to DisplayPort from HDMI Commented Oct 18, 2018 at 3:25
  • Have you checked if there's another port in the back of the display? One of my displays, too, refused to use 60Hz until I unplugged the Mac and used the other HDMI port.
    – 19h
    Commented Apr 12, 2020 at 18:42
  • Some LG 4K monitors won't support 60Hz until you set Ultra HD Deep Color ON in your monitor settings. See below
    – Baker
    Commented Jun 19, 2022 at 5:00

23 Answers 23


On my Philips 328P6V monitor, using a USB-C to DisplayPort cable with my MacBook Pro (15 inch model from 2019 with Radeon Pro 560X), I first was stuck at 4k@30Hz and couldn't get 4k@60Hz (even though the cable supports it). I had to do two things:

  1. Enable DisplayPort version 1.2 in the monitor's menu.
  2. Choose "Resolution: Default for display" in my Mac's System Preferences/Displays.

The first point is pretty obvious, given that DisplayPort 1.1 only supports 30Hz for 4k.

The second point, however, is a bit weird. The original setting was:

enter image description here

And this setting delivered 4k@30Hz. Choosing "Default for display" changed it to 60Hz. After that, even re-selecting "Scaled" keeps my monitor at 4k60Hz.

What I believe might have happened is, that when I had first connected the display, it was still set to DisplayPort 1.1, and I assume my Mac remembered this. Resetting SMC/PRAM didn't seem to help. Switching the Resolution selector in the System Preferences probably made macOS rescan the connection and remember the updated DisplayPort 1.2 capability.

  • 5
    On my LG Ultra HD I got a menu message that said "To view the 4K@60Hz ... via connected devices go to [Picture]>[Picture Adjust]>[HDMI ULTRA HD Deep Color] and change the settings into On." I tried 3 different cables before discovering this!
    – JohnQ
    Commented Apr 18, 2019 at 1:59
  • This "HDMI Ultra HD Deep Color" setting bumped me up from 30 Hz to 60 Hz as well. Using a Pixelbook. Commented Jul 4, 2019 at 18:27
  • 2
    Quickly switching to "Default for display" really does fix the issue! Thanks! Commented Mar 6, 2020 at 10:41
  • 1
    Can't believe the fix was so simple but switching to "Default for display" and then back to my scaled resolution worked for me as well, thanks! Commented Mar 20, 2020 at 16:43
  • 4
    For me, I clicked “scaled” while holding the option key, then clicked on a checkbox called “show scaled resolutions”. Then, the refresh rate was selectable. Commented May 16, 2020 at 23:58

I had the same issue on my MacBook Pro 16". You need to option+click on scaled in display settings and then select 4k resolution. Then tick the box that says "show low resolution modes" and then change the refresh rate to 60hz. Solution found/problem solved.

If this doesn't work it's your adapter or cable that is the issue.

  • 10
    I cant select 60hz I only get 30/25/24
    – ALM
    Commented Jun 11, 2020 at 0:19
  • 1
    Thanks - it works like a charm, you've made my day!
    – cyberz
    Commented Jul 1, 2020 at 9:47
  • I don't know how to pay for it but many thanks for the solution. I didn't know opt+click. I opt+clicked the display options and unchecked "high dynamic range" checkbox. That solved my problem.
    – iedmrc99
    Commented Oct 27, 2020 at 12:14
  • 5
    Wow, just wow. First of all, thank you so much for the option click trick – I cannot fathom how Apple ever thought this was a good UX design for such a menu. I have definitely use option click in other contexts, but they're equally stupid :) Commented Dec 23, 2020 at 17:47
  • thanks alot I kept on disconnecting and re connecting my cable and the solution was so simple Option+ resolution click
    – Danny
    Commented May 11, 2021 at 8:38

So I've tried a few things:

  • IOKit/CoreDisplay patch described in this article. But the patch doesn't cover AMD graphics card and is not compatible with the CodeDisplay version I have
  • Randomly re-connecting the USB-C/HDMI cable (I've seen comments claiming it works sometimes)
  • SwitchResX. It has weird UI, but it works! My display is now recognised as "SwitchResX4 LG Whatever" and does in fact run 60hz. It's not free, but I haven't found a better solution yet.

SwitchResX4 LG Whatever

  • This worked for me as well on an LG 27UD68-P 4k monitor. However, I had to play with SwitchResX settings to get it working correctly. Choose "Custom Resolutions", then add a resolution using "simplified settings" -> CVT-RB, 3820 x 2160, 59.947 Hz. Reboot, then choose the new setting from "current resolutions" and it successfully switched to 4k @ 60Hz
    – sman591
    Commented Nov 19, 2020 at 18:55


If your LG display has this setting and you're using an HDMI cable...

this setting must be ON to get 60Hz at 4K!

LG displays have this setting off by default. When off, 30Hz is max at 4K.

Turn this setting On to allow 60Hz @ 4k resolutions (and other lower resolutions).

Menu > Picture > Picture Adjust > HDMI ULTRA HD Deep Color > On

... and don't forget to...

Power Cycle the Monitor!

After setting ULTRA HD Deep Color on, you must power off and back on the monitor before your Mac will show the 60Hz refresh rate option.

Otherwise, Display Preferences will still only show 30hz, 25hz, 24hz.

Supported Resolutions & Refresh Rates

Ultra HD Deep Color setting

Deep Color on

  • 1
    This answer needs to be higher up. I've just picked up a 2nd LG 27" 4k screen to complement my first (which works at 60hz) but could I get it to run at 60hz - regardless of new 4k hdmi cables etc etc (it would do 4k 60hz via windows and display port so could confirm monitor was capable of it) You are 100% correct with it needing the ultra deep colour to be on - instant fix. Thankyou! Commented Jan 23 at 22:26

For me it was an HDMI cable issue as Bunches answered. I used the one that came with my gaming monitor and it started working. So her answer is indeed helpful, nobody else mentioned trying another HDMI cable. Unfortunately i dont have points to give you an upvote yet.

I would love to know which exact spec was a mis-match but both cables have similar labelling: -

Premium Hight Speed HDMI cable with ethernet AWM style 20276 80C 30V VW-1

The only difference is the model number:

E358026 - not working.

E474198-C - working.


I’ve had better luck using USB-C to DisplayPort with macOS to achieve 4K@60hz. Something with HDMI 2.0 was a bit of a tweak to that standard. Even using Win10 I had to specifically go into the NVidia settings and tell it to use the UHD profile to achieve 60hz over HDMI 2.0. I imagine SwitchResX is giving you that capability.

  • Amazing, this fixed my issue! Thanks!
    – WunDaii
    Commented May 22, 2020 at 18:06


  • MacBook Pro 15" 2018
  • Monitor 4k 28" Samsung U28E590
  • Cable usb-c to HDMI (Supports @60 HZ)

** I have also a dock hub dual usb-c port with outputs ports one of them HDMI and also 2 usb-c output ports.

This issue happen to me on any combination, using my dock hub or directly connecting the cable to one of the MacBook ports, I use 2 monitors this samsung 4k and the other 22" DELL FHD, also it doesn't matters if I use just the samsung monitor or both, but by default connecting the usb-c/HDMI cable to the monitor doesn't recognize the @60hz and sometimes neither all the capable resolutions it's really annoying struggle on this on a recent Macbook Pro, so when this happens I used to disconnect the cable from the usb-c on my MacBook then connect it again and finally switch the HDMI ports on the monitor and backing it up again to the correct HDMI port with the 60hz capability, THEN the resolutions are selectable and also the 60hz option to all the resolutions.

  • I can confirm this solution working for my Vu 4K TV connected to 2020 MBP 13 using a Type C to HDMI cable which supports 4k@60Hz. I connected the cable to the other HDMI port on my TV and I started to see that all resolutions higher than 1920x1080 started to show 60Hz output option. Thanks a ton. Commented Apr 27, 2023 at 14:56

I simply swapped out my cable with a thicker HDMI cable and it did the trick.

  • 1
    What was the earlier cable type? Also, is that all you can really add to the answer? Such one liners are normally frowned upon by the community. See How to Answer
    – anki
    Commented Sep 19, 2019 at 18:42

I have had this problem.

Mine is : MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports)

Bear in mind that MBP 2016-2018 models do not support 4k 60Hz in the right usb-c ports.

You should definitely check with the left ports (usually people use right ports)

And also you need to check the cables.

  • MBP has no 18" versions, a 17" version has not been produced after 2011, and the 16" version started coming out only by late 2019 vs the OP stating that it is dealing with a 2018 MBP. Pls revise your answer.
    – Alper
    Commented Mar 9, 2020 at 3:15
  • Sorry I meant 2016-2018 models. Didn't mean the size of screens. Commented Mar 10, 2020 at 5:27
  • I had exactly the same problem (the port on the right only gave me 30Hz), took me a while to figure it out. Commented Oct 29, 2020 at 13:57

I have had the same problem with that exact cable (Satechi) and a 4k TV. There is a problem with those active adapters & cables on the MacBook Pro 2017 & 2018 models. Please check your "USB" category on System Profiler, does it state that the cable is connected as "BILLBOARD 2.0" under the USB 3.0 category? For me it seems that we can't activate the "DP Alt Mode" on these thunderbolt ports (for no apparent reason). And that's why you are getting 30hz.


On Hisense, I had to open the TV settings and Select Enhanced HDMI output, and then disconnect reconnect my HDMI cable. I also had to switch from extended displays, back to mirror, and then back to extend.


In my case, one day "Default for display" workaround stopped working.

After reseting NVRAM, workaround started working as usual.


I have a MacBook Pro 15'' Mid 2015. I had a simple HDMI cable first, and MacOS only supported a 30Hz refresh rate. It was painful to use. I bought several different cables, but it was still stuck at 30Hz. I hacked a custom 60Hz crappy resolution with SwitchRes4x but that's all I could get. No 4K for me.

Then, suddenly, after resetting SMC and NVRAM AND reinstalling MacOS from scratch, 4K is working fine with a DisplayPort to ThunderBolt 2 cable (my monitor doesn't have a USB-C port)!


It may seems dumb but did you try to restart your macbook after buying and connecting this 4k sreen ? For me it seems like the right settings for my LG CX 4k tv were not visible until I restarted my macbook.

After that I went to display preferences, then use Tom Ross answer:

I had the same issue on my MacBook Pro 16". You need to option+click on scaled in display settings and then select 4k resolution. Then tick the box that says "show low resolution modes" and then change the refresh rate to 60hz. Solution found/problem solved. If this doesn't work its your adapter or cable that is the issue.


2019 16" macbook pro - I think my best solution involved changing around usb-c ports (I use Acer lcd over usb-c), turning on/off true tone in OSX, last resort would be restart and power off. It's a tricky beast, sometimes I can only see 59,88 Hz at the lowest resolution, but eventually I get 60Hz in 4K. Fingers cross for Apple to sort this out eventually.


I have a 16" 2019 MacBook with USB-c ports and a LG 34WN80C, the monitor is hooked up with a Apple USB-C -> USB-c cable. Since the last update to OSX Big Sur I noticed my monitor switched to 30hz 3440x1440.

I fixed this by manually setting the displayport version to 1.2 instead of 1.4 through the settings of the display itself. No idea why this works but now I have 60hz 3440x1440 + charging.


I had the same issue when I bought my Samsung U28E590. I had a Satechi adapter and HDMI 2.0 cables but would always get 30hz. I had to buy a new cable but usb-c to DisplayPort and the issue was fixed. I run now 4K@60Hz.


I got recently LG UltraFine 27UL650-W (MBP 16" + DP-USB-C) and had same issue with 30HZ.

Unchecking High Dynamic Range in Display settings did a trick for me. Now I have 60HZ/4K.


Using an Apple branded HDMI adapter worked for my 2019 15-inch MacBook Pro. Initially, I was using an off-brand HDMI adapter and was seeing up-to 30Hz for 4k. After switching to the Apple branded HDMI adapter, 60Hz was available.


My USB hub's HDMI port doesn't support 4K @ 60hz, while my laptop does. Upgrading to a better hub fixed it for me. Just leaving this comment here, hoping it might help someone. 2021 Macbook Pro M1.


I had the same problem with my LG Ultrafine 27UP600-W connected to my Mac Mini. It started after I swapped cables while testing a different issue. But after swapping back to the cable that came with the monitor, I still wasn't seeing 60hz as an option. Restarting didn't help either.

For me, the fix was selecting this on the monitor: Settings > Picture > Game Adjust > FreeSync > Basic.

You can safely reset FreeSync back to the factory default of Off afterward. I think switching FreeSync is what it takes for the Mac to rescan the connection to the monitor on a Mac Mini. (Chris Lercher's answer of selecting Default for Display didn't work for me.)

Edit: It looks like turning on HDMI ULTRA HD Deep Color also works: Settings > General > HDMI ULTRA HD Deep Color.


For anyone reading through this post, my solution came from this answer. I needed to switch DisplayPort version on LG monitor settings from 1.4 to 1.2, and then set refresh rate to 60Hz in MacOS Display settings. The setting wasn't available before changing DisplayPort version.

Plus make sure you're using one of the left-sided ports if on 2016-2018 Macbook Pro


Had the same problem when connecting a MacBook Air (M1, 2020) to an LG 4K screen (27BL55U-B).

I tried all the solutions suggested here with no success. Then I finally discovered that my USB-C Digital AV Multiport Adapter from Apple was the problem. I found out that there are two versions of this Adapter. The older version (Model A1621) only supports 3840 x 2160 at 30Hz while the newer version (Model A2119) supports 3840 x 2160 at 60Hz, as stated in an Apple Support Document.

I was using the older version. Now I'm using a new USB-C-to-Display-Port cable and it works nicely.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .