2

Recently I started using Microsoft Visual Studio Code instead of Atom. So I deleted Atom from the Applications folder. However, I can still autocomplete the atom command in terminal. And searching for it with where atom doesn't give any results (command not found).

I tried looking for it in ~/.zshrc but nothing there points to atom either.

Any idea where I can remove that command?

Using iTerm2 and om-my-zsh.

Update

  • The output of type -a atom is atom not found.
  • This is after a reboot of my machine; the terminal has been refreshed.
  • The output of alias does not contain atom.
  • I misremembered the which command and used where instead. That was my issue. Accepted the answer stating this.
  • Please share the output of running type -a atom in Terminal. – Nimesh Neema Oct 16 '18 at 13:29
  • @NimeshNeema atom not found. updated the question too. – SpacyRicochet Oct 16 '18 at 13:34
  • Have you tries a new terminal session? – Mark Oct 16 '18 at 13:36
  • @Mark Yes :) Updated the question. – SpacyRicochet Oct 16 '18 at 13:40
  • i'm not famiilar with the oh-my-zsh shell but in the bash shell there is a file named .bash_profile that would have an atom alias set. Have you tried typing 'which atom' in the terminal? or type 'alias' or some command to give you a list of aliases.. – jmh Oct 16 '18 at 13:57
2

where atomwill result in command not found, true, but because the where command is not found; when using bash. A zsh error would have issued "atom not found"

Try which atom to get the result of /usr/local/bin/atom in bash.

That means you just need to rm /usr/local/bin/atom to get rid of that command.

(Atom.app install also apm, so be sure to remove that as well.)

  • where is a zsh builtin command. – fd0 Oct 16 '18 at 16:26
  • @fd0 That's true. But to me it looked as if bash was used to issue that command. zsh error would have looked different – LangLangC Oct 16 '18 at 17:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .