My wifi stop working and it display "No hardware installed" message on my Macbook Pro 2018. I've tried reset NVRAM and SMC but no luck. In system rapport it looks installed, on en0 BSD. Also i've tried to remove NetworkInterfaces.plist.

enter image description here

Ps: i have an MINIX NEO C adapter and since i've used that i had this problem. First time it started to work bi itself, but second time don't want to start anymore.

  • Please do not use tag mac-pro for questions about MacBook Pro. – GEdgar Oct 18 '18 at 0:31
  • Ok, but what is stand for tag mac-pro for? @GEdgar – Florescu Cătălin Oct 18 '18 at 5:55
  • That tag is for the "Mac Pro" ... see apple.com/mac-pro – GEdgar Oct 18 '18 at 12:10
  • Note: tag macbookpro automaticaly changes to macbook. So I guess that is the proper tag for you. – GEdgar Oct 18 '18 at 12:42

Looks like wasn't a software problem, was a hardware one. Apple replaced my motherboard and touch-id. Now the WiFi is working. A little bit disappointed for my first Apple product.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .