1

I have 3 macs: a Mac Mini, a MacBook Air, and a MacBook Pro.

I have some directories mirrored on all 3 Macs via syncthing (which is awesome).

The MacBook Pro is at home; the other two are at my office.

I set up a PHP script to access an sqlite database that I use. The db file and the php script are in the directory that is mirrored.

At home, I enabled apache on the MacBook Pro. Then I made a symbolic link in my /Library/WebServer/Documents directory to the directory that is mirrored on all 3 computers.

That worked. I could (on my MacBook Pro) see localhost in a web browser, and I could see localhost/conflicts/conflicts.php. Everything worked fine.

I came to work. The files in the directory are all mirrored. Everything there is fine.

I opened the MacBook Air and in terminal logged in as an admin user, did sudo apachectl start, and the machine could see localhost. I added a symlink in the /Library/WebServer/Documents directory and the web browser could see localhost/conflicts/conflicts.php. I edited my httpd.conf file to enable php7 and boom, the php even worked.

BUT, on the Mac Mini, everything works until I get to conflicts/conflicts.php.

NOTHING I do will allow me to see that directory. I have confirmed that httpd.conf is IDENTICAL on the MacBook Pro and the Mac Mini, but I cannot see localhost/conflicts/conflicts.php. I can delete the symlink to it and the error changes to a file not found error but EVERY time the link exists, no matter what permissions are on the link and the actual directory and the actual files in it, I get a 403 error every time.

Forbidden

You don't have permission to access /conflicts/conflicts.php on this server.

I have triple checked the permissions. I have even set the permissions on the directory and the files to 777. EVERY TIME, I get the 403 error.

BOTH other computers can still see localhost/conflicts/conflicts.php but the Mac Mini insists I don't have permission to do so.

Help?

You must log in to answer this question.

Browse other questions tagged .