2

I have macbook pro, with MacOS High Sierra. The thing is, i can't connect to any websites beside those on the title, but only when i connected to a specific Wi-Fi in my office, and happened on all browser. I have no problem when i connected to my own Wi-Fi at home. And this is only happen to my macbook, my phone using same Wi-Fi but have no problem. I did follow many solutions like add google dns, flushdns, turning off ipv6, etc but none of them working. I even try to look for solution using my phone, since i can't open single link on google. Pls help, been through this for past few weeks...

enter image description here enter image description here

  • Have you talked to your network administrator in the office about this? What kind of error do you get when you access other sites? Does ping 151.101.113.67 (www.cnn.com) (or pinging any other apparently unreachable server via its IP address) in Terminal work? – nohillside Oct 15 '18 at 5:40
  • I tried to ping 151.101.113.67 just now, but it said "no route to host"... – Rei Oct 15 '18 at 5:44
  • So it's not (or not only) a DNS issue. Can you compare the network settings your Mac gets to those your iPhone gets on this WiFi? – nohillside Oct 15 '18 at 5:47
  • 2
    The IP address 169.254.XXX.XXX is a self-assigned IP or automatic private IP address. You get this when you don't get an IP address from the DHCP server. See this post for more detail – Allan Oct 15 '18 at 15:16
  • 2
    Also, if it's happening at work, more than likely there's some sort of authentication going on. See this post for more details. – Allan Oct 15 '18 at 15:19
1

I know this question is a bit old and hopefully the OP has already solved there issue but for those who are finding themselves with the same issue I'll leave what I found others doing and what worked for them and then I'll put what worked for me.

The issue seems to arise from the Mac trying to self-assign itself an IP.

  1. If you're experiencing this issue, the first thing I would try is renew the Lease in your network preferences panel: System Preferences > Network > Advanced > TCP/IP > Renew Lease

  2. Other's have also said that deleting their Wi-Fi Prefered Networks ... > Advanced > Wi-Fi fixed it for them.

  3. Other's mentioned having to delete the Wi-Fi Service in Network and re-adding it

  4. Other's suggested changing DNS to Google or OpenDNS (8.8.8.8 or 8.8.4.4 for Google)

Another solution that worked well for most was to flush the DNS:

Mac OS X Yosemite and later sudo killall -HUP mDNSResponder

Mac OS X Yosemite v10.10 through v10.10.3 sudo discoveryutil mdnsflushcache

Mac OS X Mavericks, Mountain Lion and Lion sudo killall -HUP mDNSResponder

Mac OS X Snow Leopard sudo dscacheutil -flushcache

The most common one I saw was the suggestion of going into finder and navigating to /Library/Preferences/SystemConfiguration (you can get their by pressing CMD + SHIFT + G) and deleting the following files:

  • com.apple.airport.preferences.plist
  • com.apple.network.identification.plist (or com.apple.network.eapolclient.configuration.plist depending on OS version)
  • NetworkInterfaces.plist
  • preferences.plist

And then after deleting the files reboot your computer and try connecting to your network.

Another suggestion was the firewall but because my firewall was already turned off I didn't try this method.

None of those worked for me, however. What did work for me when none of the other suggestions did was setting my IPV4 to manual (System Preferences > Network > Advanced > TCP/IP) and filling in the information as such:

IPv4 Address: 192.168.0.32
Subnet Mask: 255.255.0.0
Router: 192.168.0.1

This method requires that you know the base of the IPv4 Address. For this, you'll need another computer on your network and type ifconfig | grep inet into terminal for Mac or if your other computer is Windows you can do ipconig and find it. It usually always starts with 192.168 which can then be followed by (most commonly off of experience) 0, 1, or two. The last part of the IP I chose at random but needed it to be a value high enough that it wouldn't conflict with another device.

You can grab the router ip of this other device too. I believe most phones will display the information somewhere.

IMPORTANT NOTE is to mention that if you "played" with the IPv6 you'll need to set this back to automatic

  • Be careful, when setting up a static ip address, you could use the ip address of someone else like your boss or worse your CEO. The first person of the day who uses the address wins. – historystamp May 17 at 21:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .