I have a 2012 15" MacBook Pro and the Bluetooth is "unavailable". It has been like this for a while actually, probably about a year and a half. Sometimes it randomly becomes available and turns on only to become unavailable again only minutes later. Also a Bluetooth setup wizard app opens sometimes, usually after I turn the computer on after it had shut off from low battery, but when I click on it nothing happens. I haven't cared about this issue too much because I didn't have anything connected using Bluetooth, but now I actually do have something that I want to connect. I have tried resetting the SMC, deleting the .plist file and restarting, but neither of these worked. Does anyone know what might solve this issue?

  • 1
    what OS X is it
    – Ruskes
    Commented Oct 15, 2018 at 4:13
  • 1
    hold Option+Shift and click on BT icon in the menu bar. New menu opens with Debug options.
    – Ruskes
    Commented Oct 15, 2018 at 4:18
  • Mac OS Mojave but it did it on Sierra as well. Commented Oct 19, 2018 at 0:37
  • I have tried holding option + shift and then clicking on the Bluetooth icon but nothing different comes up, just the same "Bluetooth: Not Available". Just tried it again and it doesn't work. Very strange. Commented Oct 19, 2018 at 0:39
  • does it show in About this Mac > System Report > Bluetooth
    – Ruskes
    Commented Oct 19, 2018 at 0:42

2 Answers 2

  1. Delete Bluetooth paired list
  2. Close any Bluetooth associated file that may hinder the process
  3. Copy/Paste following and Press the combination Command + Shift + G


Rename it so to save a copy com.apple.Bluetooth-Old.plist

Now delete the original file and restart your Mac, it should create new Plist.

Alternative approach

Press ⌘ Space to activate Spotlight.

Type "bluetooth", choose the 'Bluetooth File Exchange' application, and press Return.

Bluetooth File Exchange will prompt to enable the bluetooth hardware, press Return.

Bluetooth is now enabled and you can quit Bluetooth File Exchange.

Here it is what it looks on my MBA



In terminal, also remove the com.apple.driver.AppleBluetoothMultitouch.trackpad.plist and com.apple.driver.AppleBluetoothMultitouch.mouse.plist files from ~/Library/Preferences.

cd ~/Library/Preferences
sudo rm com.apple.driver.AppleBluetoothMultitouch.mouse.plist
sudo rm com.apple.driver.AppleBluetoothMultitouch.trackpad.plist

Then restart. That fixed it for me.

  • Why you need sudo to handle files in your own ~ home directory? Commented Mar 12, 2019 at 2:00

Not the answer you're looking for? Browse other questions tagged .