1

Recently I decided to enable FileVault on my MBA mid 2012 running Sierra 10.12.

Things that happened so far in a chronological order:

  1. After turning it on in Settings.app it seemed stuck so I forced shut it down. Afterwards it seemed ok for a bit and then suddenly the keyboard did not work (afaik the trackpad still worked).
  2. I removed the bottom case and unplugged the battery. Suddenly, the keyboard worked again, but the fans were going crazy and the CPU was throttled because the battery was missing. When the battery was plugged in again, the keyboard stopped working again. Very strange behaviour.
  3. After some time, I decided to remove and reattach the flex cable connecting the logic board with the trackpad / keyboard. No luck, but the fan was quiet again.
  4. At this time only external mouse and keyboard worked. Following suggestions online, I turned off FileVault but the keyboard was still broken.
  5. I tried to reset the SMC multiple times with they key combos. As I feared that the SMC might be corrupt from the force shutdown in 1., I manually flashed it with refind and SMCFlasherTool. No luck.
  6. Other uses with similar problems said that replacing the flex cable helped them. So I ordered one, but the keyboard / trackpad still do not work except for the power key.
  7. I have two partitions on the SSD, one is running Yosemite. Keyboard / trackpad do not work there, either. Even after reinstalling Yosemite.

I also tried the following:

  • Resetting SMC, NVRAM etc. multiple times.
  • Trying to boot in safe mode, but the shift key is not recognised.
  • cmd+v did not work either.
  • Re-enabling and disabling FileVault.
  • Booting into recovery: Internal keyboard / trackpad do not work there either.
  • Replaced the original battery with a brand new one from iFixit. The battery was recognized and worked but it didn't help.

Current situation:

  • Original battery is working again. Fans do not go crazy when it is plugged in and CPU does not throttle.
  • Only external keyboard / mouse are working.
  • On the internal keyboard, only the power button works. I can turn the Macbook on with it. Force shutdown also works. I tried to reset the SMC when it was logged in. Pressing ctrl + option + shift + power button immediately turns the machine off. I do not know if this is the normal behaviour.
  • Strangely, when I press F5 and F6 on the external keyboard, the illumination of the internal keyboard changes. So apprently, it is recognized.
  • I cannot boot the into the Apple Hardware Test by pressing D on the external keyboard. Nor does booting in the safe mode works with shift.

Any ideas?

  • 1
    Maybe it's just a strange coincidence. How old is your battery? – nohillside Oct 14 '18 at 13:37
  • 1
    6 years. But I have also tested it with a new battery from iFixit. – wizoo Oct 14 '18 at 13:38
  • 1
    Well, the old battery could have damaged keyboard/trackpad nevertheless in case it's swollen. – nohillside Oct 14 '18 at 13:42
  • 1
    Honestly, especially since you already did a lot of analysis yourself: I suspect a hardware issue. – nohillside Oct 14 '18 at 13:43
  • Well... this is really disappointing. I tried using Apple's built-in features that lead to this situation. Maybe they are responsible for this, I don't know. The battery is not swollen and works like before now. – wizoo Oct 15 '18 at 18:51

You must log in to answer this question.

Browse other questions tagged .