1

I cannot print from Notes on my iPhone 6s+ since updating my phone to iOS 12.0 and I get the following error: No AirPrint Printers Found. My bonjour printer settings have not changed, and my router settings have not changed. I have tried 2 printers so far: a Canon MX512 and a Canon MX452. I actually noticed the MX512 stopped working a few months back, although Airprint was definitely still working with my MX452 until the most recent update. Both printers work fine with my laptop. What could be the cause/how can I fix this?

  • Have you tried updating the firmware on your printers? I have an Epson inkjet and I had to run their utility to do the update, now I can see it on my iPhone X. Also, you might try running the network setup on the printers again, see if that helps. – fsb Oct 13 '18 at 14:18
1

I have had the same issue. The only way, temporary at best, I could see the printer from my iOS device was to change the Bonjour name of the printer from the local network site for the printer. Works once, and then same issue recurs, though.

0

With several versions of iOS 12 out, if you still have this issue with updating your iOS, it’s clear you’ll need to get into troubleshooting your network or contact the vendor of your printer.

AirPrint still works on iOS 12 and if there were widespread issues, we would have a whole lot more questions here about it.

Also, have you wiped your iPhone and restored it as new (or done an erase all content and settings) and then tested AirPrint without loading your backup? It could just be an issue with your installation of iOS and not that the printer is not going to work with iOS 12.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .