5

I have a 1TB main drive where ~400GB seemingly got stuck in /Volumes/Time Machine Backups/ after the 10.14 update.

I managed to delete most of it, but some files and folders are extremely resilient to being deleted.

For example I am stuck with a folder:

/Volumes/Time Machine[...]/private/var/db/ConfigurationProfiles`

I am unable to delete it, even trying rm -rf as root. When I examine the folder from the terminal I get:

sh-3.2# whoami
root

sh-3.2# pwd
/Volumes/Time Machine[...]/private/var/db/ConfigurationProfiles

sh-3.2# ls -la
ls: Store: Operation not permitted
total 0
drwxr-xr-x@ 3 root  wheel  96 Oct 12 22:18 .
drwxr-xr-x@ 3 root  wheel  96 Oct 12 22:18 ..

Interestingly enough, when I open the same folder in mc, a file ?Store is present:

enter image description here

Since I have a bunch of folders around with similar problems, I was wondering what the easiest and most convenient way to delete all of them is.

Things I tried that don't work:

  • sudo rm -rf ...
  • mc -> F8
  • Granting Terminal full disk access in security settings

Is there a tool or simple command that acts like rm -f and really just deletes a file, no matter what?

  • Let me guess: You also can't access Store through ll /private/var/db/ConfigurationProfiles (on your main disk, not the backup)? – nohillside Oct 13 '18 at 12:25
  • If I run ls -la /private/var/db/ConfigurationProfiles I get ls: Store: Operation not permitted. – left4bread Oct 13 '18 at 16:53
  • What happens if you disable SIP? Not being able to do things as root is an indication that SIP is blocking you. – Gilby Oct 16 '18 at 21:40
  • @Gilby This was my first thought too, but SIP shouldn’t be preventing the deletion of files on an external volume! It only applies to the boot volume. – Wowfunhappy Oct 16 '18 at 22:53
  • Have you tried running first aid on the disk? I wonder if there's some file system corruption at play here... – Wowfunhappy Oct 16 '18 at 23:26

You must log in to answer this question.

Browse other questions tagged .