10

I occasionally need to check some file's location and copy it to the clipboard. I used to use Finder -> Cmd-I then I used to copy the content of "Where" section.

Ever since updating to macOs Mojave, the format of the path displayed in the "Where" section has changed. Instead of "/" forward slash character now I see "triangle" character.

triangle in path

How to solve this?

Thanks!

  • 2
    I also find this problem and haven't found a solution. This is a really bad change and It seems that Apple haven't fixed this issue. – CTW Dec 25 '18 at 2:17
15

You can select the file and press Option + Command + C to copy the pathname to the clipboard.

You can also use Control + Option + right click in macOS Mojave (copy as pathname will replace copy file in get info modal). Little change but I just found it. Still works on networked drives too.

| improve this answer | |
  • Note: Running Mac OSX Mojave 10.14.6, and Control is unnecessary. I right click on the file, then hold Option to get the modal menu with the pathname option. – jvriesem Feb 27 at 0:49
  • @jvriesem Not working for me (mojave) after many attempts: but the original answer here does work – javadba Apr 9 at 11:47
  • @javadba: Odd! I'm also running Mojave (10.14.6), and the following does work for me: 1) Right click on the file in Finder (on the desktop, in a folder) to bring up the menu. While the menu is open, hold Option, and the menu options change slightly. One of the options for me (for a file called filename.txt) is Copy "filename.txt" as Pathname. If that doesn't work for you, what numeric version of MacOS are you using? – jvriesem Apr 9 at 14:49
11
  1. Right Click on Folder/File
  2. Hold down the Option key
  3. Select Copy "[filename]" as pathname
  4. Paste to wherever you need it

enter image description here

| improve this answer | |
  • This one actually works – javadba Apr 9 at 16:22
-1

Even though the Info window shows triangles, selecting and copying the text will copy the path with slashes.

That said, this answer is probably a better solution.

| improve this answer | |
  • 3
    On high sierra, it copies with slashes, but on mojave it seems to copy weird triangle characters instead of slashes. – Steven Peters Oct 13 '18 at 4:03
  • I confirm that on Mojave it copies with the triangles. – Rade_303 Oct 16 '18 at 15:27

Not the answer you're looking for? Browse other questions tagged .