3

my Finder is not able to connect to ANY smb-share. It doesn't matter, if the network-folder

  • is on linux (SAMBA 4.1.17)
  • is on OSX (10.11.6)
  • is on Windowsserver
  • is public for everyone or in a ADS

It simply stops in the Finder with "Couldn't connect"

In the terminal you see the following

$ ping server
PING server (192.168.0.123): 56 data bytes
64 bytes from 192.168.0.123: icmp_seq=0 ttl=64 time=1.017 ms
^C
$ mount_smbfs  //johndoe@server/johndoe test
mount_smbfs: server connection failed: No such file or directory

on a Debian-VM on the same macbookpro following command works perfectly

$ mount.cifs -o username=johndoe //server/johndoe test

In the logs is nothing, despite having kloglevel=15 in /etc/nsmb.conf and i have already tried 'configureLocalKDC' to reset the krb5.keytab

So i disabled System Integrity Protection and made a dtruss for the first command.

dtruss -cf mount_smbfs  //johndoe@server/johndoe test >& mount.log

mount.log has 2050 open-calls for the /dev/nsmb..

15734/0x1b2bd3:  open("/dev/nsmb\0", 0x2, 0x5F719DF8)            = -1 Err#2
15734/0x1b2bd3:  open("/dev/nsmb0\0", 0x2, 0xFFFFFFFFE84BC430)           = -1 Err#6
.... 2050times ...
15734/0x1b2bd3:  open("/dev/nsmb3fd\0", 0x2, 0xFFFFFFFFE84BC820)                 = -1 Err#2
15734/0x1b2bd3:  open("/dev/nsmb3fe\0", 0x2, 0xFFFFFFFFE84BC820)                 = -1 Err#2
15734/0x1b2bd3:  open("/dev/nsmb3ff\0", 0x2, 0xFFFFFFFFE84BC820)                 = -1 Err#2

/dev/nsmb0 exists .. the other ones not. smbfs-module is loaded

$ kextstat | grep smb
  184    0 0xffffff7f8700b000 0x63000    0x63000    com.apple.filesystems.smbfs (3.2.3) 8BD2FFC5-F081-3B29-B2AB-BEF58E24BAAD 

Has anyone hints, what I could do? I already tried mb_neg=smb3_only, protocol_vers_map and so on

Thanks

2

Oh my god..

it appears to be a problem with a 3rd party kext

see Mac mini can't connect to my corporate SMB server. Was working some days ago

WTF apple. Fix your damn Error messages.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .